Nemo not default nor can be set as default

I realized today my install of Cinnamon does not have a default file manager.
Nemo is installed, and works, but it is not default nor can it be set as default, it is not available in the list. (See screenshot).

Edit: I still don’t know WHY, but in the terminal it worked with:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

Of course this should not be neccesary, and Nemo still doesn’t show up in the list of possible choices. But it is set, and I won’t remove it, so… all good I… guess?

I still want to know what causes this bug but at least it works.

I just installed Cinnamon again just for something to do. Nemo is installed and working as preferred app. So what else did you install? Terminal? and ?? Maybe something you added?

1 Like

I think I figured out… not the EXACT cause but the suspect:

I didn’t do a reinstall, I just purged Xfce completely and installed Cinnamon.
HOWEVER: I had already set Nemo as default file manager in Xfce, as I usually do (I REALLY don’t like Thunar).

I wonder if by purging Xfce with Nemo already installed and set as default somehow got a dot file somewhere to indicate that Nemo doesn’t exist? Even after reinstalling it?

Do you have all these installed?

Maybe check in ~./config for thunar?
Edit: You may be right if you removed Xfce that way?