Need Plank Help (It looks rough)

Timeline: yesteday. did an update or two. worked from home. no problems. shutdown. bed
Today: work away from home. Come back home. Boot Endeavour. Plank would not launch.
Tried it from “Run”, nothing.
Plank --preferences = nothing

sudo pacman -Rn plank
sudo pacman  -S plank

terminal: NADA. no output no launch.
SUDO terminal, on the other hand:

$ plank
$ sudo plank
[WARN 13:59:18.340082] [Environment:165] XDG_SESSION_CLASS not set in this environment!
[WARN 13:59:18.340133] [Environment:196] XDG_SESSION_TYPE not set in this environment!
[CRITICAL 13:59:18.342950] [Wnck] wnck_set_client_type: changing the client type is not supported.
[CRITICAL 13:59:18.364835] [DBusManager:192] Not able to register our interfaces
[WARN 13:59:18.457749] Unable to get org.ayatana.bamf matcher: Error spawning command line “dbus-launch --autolaunch=5266cb68207c49639612d12b1e416a6a --binary-syntax --close-stderr”: Child process exited with code 1
[CRITICAL 13:59:18.462951] [GLib-GIO] g_dbus_proxy_set_default_timeout: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[CRITICAL 13:59:18.462971] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.467540] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.467547] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.472137] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.472144] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.476765] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.476783] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.481635] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.481643] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.486352] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.486369] [GLib-GObject] invalid (NULL) pointer instance
[CRITICAL 13:59:18.491017] [GLib-GObject] g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
[CRITICAL 13:59:18.497735] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 13:59:18.498163] Failed to get running applications: 
[CRITICAL 13:59:18.499062] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 13:59:18.505401] (Services/Matcher.c:299):plank_matcher_active_launchers: runtime check failed: (_tmp3_ != NULL)
[CRITICAL 13:59:18.509531] [GLib-GIO] g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
[WARN 13:59:18.509837] Failed to register favorites: 
[CRITICAL 13:59:18.510755] [GLib] g_error_free: assertion 'error != NULL' failed
[WARN 13:59:18.513601] [Unity:92] Error spawning command line “dbus-launch --autolaunch=5266cb68207c49639612d12b1e416a6a --binary-syntax --close-stderr”: Child process exited with code 1
[WARN 13:59:18.515944] [Unity:92] Error spawning command line “dbus-launch --autolaunch=5266cb68207c49639612d12b1e416a6a --binary-syntax --close-stderr”: Child process exited with code 1
[CRITICAL 13:59:18.519266] [DockWindow:298] Retry #1 update_size_and_position() to force requested values!

(plank:2379): dconf-WARNING **: 13:59:21.519: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=5266cb68207c49639612d12b1e416a6a --binary-syntax --close-stderr”: Child process exited with code 1

Two quick questions: 1) what the he** does all this mean?
and 2) how do I rise Plank from the dead?
thank you

Does it launch when you use sudo in the terminal? Or does it just give a bunch of errors?

Also, you probably need to delete/rename your plank config directory at .config/plank and try launching it with your regular user again.

1 Like

no launch from sudo.

will try that, thank you

there is no config file for plank, just launch stuff text items. let me look in filesystem

Other locations are .cache/plank and .local/share/plank.

1 Like

both those folders eerily empty. nothing in trash.
worked til about 10. sober. no poking around more than normal (I am the curious cat).

surprised a uninstall/reinstall did not repopulate these folders…

lemme look in ~/xdg folder. and dconf for kicks.

HOLY CRAP I tried a ton of stuff and got nowhere.

but idly double-clicking where dock was….launches all the apps

PLANK IS INVISIBLE. and in its usual position. that’s why plank --preferences also invisible.

What fresh hell is this?

edit: is there a pacman check broken packages command?

What’s your DE/WM? And do you have a compositor running?

in lxde and using picom by necessity. I amend the picom.conf every other day because changes never stick. we both had that sinking compositor feeling at the same time now. this is likely self-inflicted then. lemme double check all the opactiy stuff. I never made any change in any category (fade, shadows, etc etc) except opacity so maybe this will be easy…

So, I know you said there is nothing in the three folders plank folders mentioned before, but try killing plank fully, then delete/rename the three folders and launch plank again.

I will try that.
In the meantime, FRESH HELL A BEDTIME STORY:

opened /.config version of plank.conf and chaged the 0 (it’s ALWAYS IN 0 why the problem now?) to 100:

poof! Plank is back except that awful background is back, that’s why we have picom and we set opacity to 0. Never been a problem before:
pi2

so back to .conf file. Put the 0 back in:
pi3

then glory:
pi4

then reboot:
INVISIBLE PLANK AGAIN.
This is an LXDE ulcer or a PICOM or XDG headache. I need a drink then I will try your remedy :slight_smile:

this is the folder:

so trash all this and reboot? I will after dinner.

This isn’t Windoze. You don’t need to reboot.

Just delete/rename the three (3) directories *after fully killing plank*, then restart plank.

you mean the 3 in the pic: /.config plank and dock1 and launchers?

ccl

edit/or you mean the three in .cache, .config, and .local?

The folder .config/plank and

1 Like

SOLVED.

am restored. rebooted anyway. have --prefs back as well.
Picom as it should be at 0…

conclusion: there was no picom problem per se, no plank.conf at all…gut says LXDE session buggery–that controls everything.

@ddnn This is the second time, at least, that your patience and goodwill helped me out of a jam. I thank you very much.

1 Like

I’m always patient, so long as the person I’m trying to help is actually trying. So thanks for being you man. :handshake:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.