Need Help with Nvidia Drivers:N/A

Secure boot say’s it’ enabled and should be disabled.

Edit: This shows Windows 10? Are you dual booting with Windows? If so you need to turn off fast startup in Windows under power management.

I play valorant, I enabled it to play then booted into BIOS to capture screenshots for you.

Yes, I installed it to play valorant, 2 days ago. So it wasn’t there before. I am gonna disable fast startup and check if nouveou works, because it didn’t when I tried installing it again.

It doesn’t show anything related to the graphics that i see. I just looked up the specs on the laptop based on the serial number provided in the UEFI images and this laptop does not have an nvidia mobile graphics card. Can you confirm that this is the correct model and serial number.

HP ENVY - 17m-ce0013dx

Serial Number

Yes this is the exact model, It’s an error on HP’s side I believe.

Weird… doesn’t show an nvidia card in the specs. But it does show from your log with the bus error.

02:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX250] [10de:1d13] (rev a1)
	Subsystem: Hewlett-Packard Company GP108M [GeForce MX250] [103c:85e5]
	!!! Unknown header type 7f

Same Laptop :slight_smile:

If you can disable the fast startup feature in Windows under power management would be good to see and reboot into Windows after doing so before booting back into EndeavourOS. It may be that it’s gone into sleep mode for the nvidia chip.

Yes i believe you but it’s just weird that the specs show even when looked up with the serial number of the product that it doesn’t have nvidia. :rofl:

:joy::rofl: Yea I didn’t blame you but same it’s weird af lol.

Tried it, no luck.

Should I finally sell this PoS laptop?

From what i see especially in the UEFI Bios and my dealings with many nvidia related hybrid laptops. It looks to me that when you install EndeavourOS with Nvidia it should either show the drivers listed as installed or it will only show them when you switch which i believe would be done with prime or optimus-manager or envy control?

If you ever do i would suggest getting a non hybrid Ryzen with AMD graphics.

Well I did install while selecting that option Nvidia. But I still installed them again using Nvidia-inst. So should I try reinstalling the OS?

I’d suggest you

  • make sure you have the USB installer available in case it is needed
  • move file optimus-manager.conf into /root temporarily
  • blacklist Intel’s i915 in your kernel parameters (see the Arch wiki about how to do so)
  • make sure you have nvidia-dkms and related packages installed (and needed linux headers)
  • reboot

I saw this too but it seems related in that particular instance to the ethernet port? Not sure if that is correct but also not sure how to fix the error messaging.

You suggested me that already and I have tried it already. It resulted in a black screen. Had to live boot and remove ‘’‘blacklist i915’‘’

I think if it were me i would try a reinstall using the nvidia option. As soon as it is installed check the graphics output with inxi -Ga

Then we have a clean slate to maybe blacklist after the i915 if needed to try.

PCIe device falls off the bus.

could be two things card slot not properly fixed but also the Bios/Firmware having issue managing the pci busses… or underpowered device …

But it was working with Windows, right?

1 Like