Need Help with Nvidia Drivers:N/A

Hey guys, I have a problem with setting up nvidia drivers. I used the provided nvidia-inst script and checked using --driver it says series 545 supported.
My system is a HP Laptop with Nvidia Optimus MX250.
I installed drivers using that script, Now when I run inxi -G it says next to my card Drivers: N/A.

inxi -G

 Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX250] driver: N/A
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4

dmesg | grep -e nvidia:

[    3.156854] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[    3.157825] nvidia 0000:02:00.0: Unable to change power state from D3cold to D0, device inaccessible
[    3.157945] nvidia: probe of 0000:02:00.0 failed with error -1
[    3.158203] nvidia-nvlink: Unregistered Nvlink Core, major device number 237

nvidia-inst --drivers

NVIDIA card id: 1d13
Fetching driver data from nvidia.com ...

Series 545: supported (nvidia.com: 545.29.06)

I am scratching my head over this since last week, tried reinstalling drivers, Changing kernels, etc.

Welcome aboard! :smile:

What do commands

nvidia-inst -t
pacman -Qs nvidia

show?

1 Like
pacman -Qs nvidia
local/egl-wayland 2:1.1.13-1
    EGLStream-based Wayland external platform
local/ffnvcodec-headers 12.1.14.0-1
    FFmpeg version of headers required to interface with Nvidias codec APIs
local/libva-nvidia-driver-git 0.0.11.r13.g42f563e-1
    VA-API implementation that uses NVDEC as a backend (git version)
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 545.29.06-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 545.29.06-3
    NVIDIA drivers - module sources
local/nvidia-hook 1.5-1
    pacman hook for nvidia
local/nvidia-inst 23.1-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-prime 1.0-4
    NVIDIA Prime Render Offload configuration and utilities
local/nvidia-settings 545.29.06-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 545.29.06-3
    NVIDIA drivers utilities
local/nvtop 3.0.2-1
    GPUs process monitoring for AMD, Intel and NVIDIA
local/opencl-nvidia 545.29.06-3
    OpenCL implemention for NVIDIA
2024-02-03 18:21:00: Info: Running: nvidia-inst v23.1-1
2024-02-03 18:21:00: Info: Command line: nvidia-inst -t
2024-02-03 18:21:00: Info: Selected mode: nvidia
NVIDIA card id: 1d13
Fetching driver data from nvidia.com ...
2024-02-03 18:21:06: Info: Removing packages: nvidia-prime
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
COMMANDS TO RUN:
    pacman -Rs --noconfirm --noprogressbar --nodeps nvidia-prime
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thank you so much for the warm welcome! I’m thrilled to be part of the EndeavourOS community.

1 Like

Just to ask the obvious: did you reboot after installing the driver?

yes I did that, like a 100 times already.

For the record, can you show the output of

inxi -Fza

I don’t know if this helps but here’s something strange I noticed when running lspci command.
Why does kernel modules show Nouveau?

02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1)
	Subsystem: Hewlett-Packard Company GP108M [GeForce MX250]
	Kernel modules: nouveau, nvidia_drm, nvidia
System:
  Kernel: 6.7.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm parameters: BOOT_IMAGE=/vmlinuz-linux-zen
    root=UUID=4d6d85ad-8394-471f-a272-385246a61a35 rw rootflags=subvol=@
    resume=UUID=6445312d-19e3-4d24-9748-e65fcaeb06dc nowatchdog nvme_load=YES
    queit loglevel=3 splash intel_iommu=on vt.global_cursor_default=0
    nvidia-drm.modeset=1
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Hyper-Arch
Machine:
  Type: Laptop System: HP product: HP ENVY Laptop 17m-ce0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 85E5 v: 30.32 serial: <superuser required> UEFI: Insyde
    v: F.18 date: 08/14/2023
Battery:
  ID-1: BAT0 charge: 32.9 Wh (60.6%) condition: 54.3/54.3 Wh (100.0%)
    volts: 11.2 min: 11.6 model: 333-54-2C-A LK03055XL type: Li-ion
    serial: <filter> status: discharging
CPU:
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 600 high: 801 min/max: 400/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 400 3: 800 4: 400
    5: 400 6: 801 7: 400 8: 800 bogomips: 31999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard
    driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: speed: Unknown lanes: 63
    link-max: gen: 6 speed: 64 GT/s bus-ID: 02:00.0 chip-ID: 10de:1d13
    class-ID: 0302
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: Hyprland driver: X: loaded: modesetting dri: iris gpu: i915
    display-ID: 1
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris wayland:
    drv: iris x11: drv: iris
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.3.5-arch1.1
    note: incomplete (EGL sourced) renderer: Mesa Intel UHD Graphics 620 (WHL
    GT2), llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0401
  API: ALSA v: k6.7.3-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: N/A modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:3
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c010c
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
  Local Storage: total: 238.47 GiB used: 55.99 GiB (23.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SSD 256GB size: 238.47 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 18E3 scheme: GPT
Partition:
  ID-1: / raw-size: 136.38 GiB size: 136.38 GiB (100.00%)
    used: 55.53 GiB (40.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-2: /boot raw-size: 1024 MiB size: 1022 MiB (99.80%)
    used: 468.3 MiB (45.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 136.38 GiB size: 136.38 GiB (100.00%)
    used: 55.53 GiB (40.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-4: /var/log raw-size: 136.38 GiB size: 136.38 GiB (100.00%)
    used: 55.53 GiB (40.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 13.21 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda5 maj-min: 8:5
Sensors:
  System Temperatures: cpu: 58.0 C pch: 50.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 254 Uptime: 55m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 15.35 GiB used: 3.01 GiB (19.6%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: pm: dpkg
  pkgs: 0 pm: pacman pkgs: 1355 libs: 302 tools: yay Shell: Zsh v: 5.9
  running-in: kitty inxi: 3.3.31

if you’re confused by the distro name, I changed it lol.

Interesting name!

All looks normal otherwise but wayland is known to have problems with some Nvidia GPUs/drivers.
Also, I’m not using hyprland, so cannot help much with that. But here we have hyprland users, hopefully some will chime in and help.

1 Like

ah okay thanks for your help. I can switch to KDE-Plasma if you want because I am facing the same issue there as well.

With wayland or x11?

With X11

In that case I’d recommend looking at the Arch wiki about nvidia. Your gpu might need some special parameter or setting to function properly.

I have read that wiki completely, have been tinkering with stuff since a week.

I don’t have many ideas, but trying different kernels might work around the issue. Worth a try unless you didn’t already.

Welp, Have tried that already. :sob:

OK. Then I hope some Nvidia guru(s) can chime in. :wink:

1 Like

Still one thing: is there a setting in your motherboard BIOS for selecting which GPU is used? If so, it might have the wrong value…