Need help with Nvidia 390xx utils driver installation nightmare




I made many-a-failed attempt to use dkms as method to install Proprietary Nvidia driver 390xx which is required by GTX 660. I look all over the Arch and Endeavour wiki’s for solutions, Steam happens to both be my critearium to test if I have made Nvidia proprietary drivers functional, and is a highly related topic as it is first application newbie such as me run into with non-functional Nvidia proprietary drivers, of which installation of cannot be completed properly and contains conflicts, and indeed articles about getting Steam to work on arch can contain the solutions to getting Nvidia proprietary drivers working like I seek. With that being said, these solutions have not worked for me.
https://aur.archlinux.org/packages/lib32-nvidia-390xx-utils/

Solutions that have not worked for me include but are not limited too: Removing everything Nvidia related and gaining ability to start clean driver installation fresh via pacman -Rsu, Trying to install lib32-nvidia-390xx-utils 390.144-1 via AUR, which is not a package avialible to install via AUR and I am convinced that it does not exist. Rational for seeking to obtain said package in the first place was that my Nvidia utils “ensure that the package version matches nvidia” (https://wiki.archlinux.org/title/Steam/Troubleshooting#Steam:_An_X_Error_occurred Steam: An X error occurred".
In addition, I update mirrors and pacman mirrors constantly, and my EndeavourOS system is all up to date and what not. I would appreciate help with having Proprietary Nvidia drivers installed without any conflicts. This has been a nightmare for me spanning days.

It looks like you have the 495-utils installed for some reason so remove those first if you want the 390xx
sudo pacman -R lib32-nvidia-utils
then install the 390xx packages
sudo pacman -S lib32-nvidia-390xx-utils nvidia-390xx-dkms nvidia-390xx-settings nvidia-390xx-utils
then post your output of the result of that here

2 Likes

@SDF1

You can run the nvidia installer and revert back to nouveau open source drivers first and then reinstall the drivers correctly.

sudo nvidia-installer-dkms-n
2 Likes

Nice thread title :joy: no worries you will get help.

Welcome to endeavour OS, nvidia is a pain but shouldn’t be too hard to install.

By the way, I can’t emphasize enough, reddit is not a trustworthy source for fixing your system. Glad you found your way to the forum.

3 Likes

Unfortunantly all of those commands are error target not found.

[14:58:28] joekamprad :: UNGEHEUER64  ➜  ~ » yay -Ss nvidia-390xx                                                                                         130 ↵
aur/mhwd-nvidia-390xx 390.143-1 (+2 1.05) 
    mhwd-nvidia-390xx PCI ID database
aur/lib32-opencl-nvidia-390xx 390.144-1 (+12 0.48) 
    OpenCL implemention for NVIDIA (32-bit), 390xx legacy branch
aur/lib32-nvidia-390xx-utils 390.144-1 (+12 0.48) 
    NVIDIA drivers utilities (32-bit), 390xx legacy branch
aur/nvidia-390xx-settings 390.144-1 (+22 2.41) 
    Tool for configuring the NVIDIA graphics driver, 390xx legacy branch
aur/nvidia-390xx-dkms 390.144-3 (+36 3.20) 
    NVIDIA drivers - module sources
aur/opencl-nvidia-390xx 390.144-3 (+36 3.20) 
    OpenCL implemention for NVIDIA
aur/nvidia-390xx-utils 390.144-3 (+36 3.20) 
    NVIDIA drivers utilities
aur/nvidia-390xx 390.144-1 (+54 1.01) 
    NVIDIA drivers for linux, 390xx legacy branch

pacman will not build from AUR you need to use yay :wink:

yay -S lib32-nvidia-390xx-utils nvidia-390xx-dkms nvidia-390xx-settings nvidia-390xx-utils

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.