Need help with Mozillavpn crashing and giving segfault

Hi everyone, first time posting, this issue has been driving me nuts so any help would be appreciated.

I have downloaded this package for mozillavpn from the AUR using yay:

However, it will not launch at all. When I try to run it, I simply get a “Segmentation fault (core dump).” I have taken a closer look and it is telling me that it has “failed to start the mozillavpn DBus service” and the signal code is 11.

Been trying to figure this one out and I ran a gdb trace on the coredump and got this in the log:

Thread 1 (Thread 0x7ffff254f840 (LWP 2862) “mozillavpn”):
#0 0x00005555555f915f in ()
#1 0x00005555555f966d in ()
#2 0x00007ffff58e743b in __libc_start_main_impl () at /usr/lib/
#3 0x00005555555fbec5 in ()

I am fairly new to linux so I have no clue what to do with this information. Hoping someone could help me with this.

I am running a fresh install of EOS Atlantis Neo on a brand new Framework laptop. I have tried running a brief memtest for 30min and got no errors. I somehow doubt it is a hardware issue, as I don’t seem to have any problems running other AUR packages (I tried Mullvadvpn and it runs fine, might just have to switch to that). I have even tried to re-seat my ram to no avail.

Isn’t mullvad the better choice anyway? Mullvad is 5 Euros per month, if you want that price with mozilla vpn you have to pay for a 12 month period.

Just a thought:
Have you enabled and started the service?

sudo systemctl enable --now mozillavpn.service

Yeah I have tried this, launching the program this way is what originally caused me the error.

Yeah I am thinking the same. I bought Mozillavpn because I wanted to support Mozilla/Firefox, I had originally used Mullvad though. I think it actually works out a bit cheaper for me through Mozilla because they charge $5 USD rather than 5 euro.

This implies it’s an issue with libc, which was recently updated from 2.33 to 2.35.

Have you tried rebuilding the package?

Is libc the same as glibc? I have glibc and notice it is at 2.35-2 and I reinstalled it using octopi. Though I think I always had this version since my install is very fresh (as of two days ago). I also completely reinstalled mozillavpn again with no luck, still getting the same error.