Need help with Anacron

I had this setup in manjaro where I used anacron in user mode to run backups daily. I followed this -

Here’s my crontab

crontab -l              
# run anacron to check daily/monthly/weekly
01 * * * * /usr/sbin/anacron -t /home/akya/.anacron/anacrontab -S /home/akya/.anacron/spool

# run hourly jobs
01 * * * * nice run-parts /home/akya/.anacron/cron.hourly

My anacrontab in ~/.anacron/anacrontab

# /etc/anacrontab: configuration file for anacron

# See anacron(8) and anacrontab(5) for details.

# the maximal random delay added to the base delay of the jobs
# the jobs will be started during the following hours only

#period in days   delay in minutes   job-identifier   command
1	5	cron.daily		nice run-parts /home/akya/.anacron/cron.daily >> /home/akya/.anacron/logs/daily-backup.log 2>&1
7	25	cron.weekly		nice run-parts /home/akya/.anacron/cron.weekly >> /home/akya/.anacron/logs/weekly-backup.log 2>&1
@monthly 45	cron.monthly		nice run-parts /home/akya/.anacron/cron.monthly >> /home/akya/.anacron/logs/monthly-backup.log 2>&1

Then I linked my backup scripts in the folders as mentioned in the article. They have proper permissions. This exact setup worked in manjaro. But not working in EndeavourOS. Here is my journalctl from today -

I suspect it’s some minor issue or something I am missing. Would love some help, thank you!

What isn’t working specifically? From the logs it looks like anacron is running.

It also looks like one of your hourly cron jobs is crashing.

The shell scripts that just compress and encrypt some folders aren’t executing. I tried running cron like this -

run-parts /etc/cron.hourly

and that gave me this error.

Jan 11 17:55:39 quady anacron[42350]: Anacron started on 2022-01-11
Jan 11 17:55:39 quady anacron[42350]: Can't open timestamp file for job cron.daily: Permission denied

The stuff in /etc/cron.hourly is probably supposed to be run as root.

You configured your cron jobs to be in /home/akya/.anacron/cron.hourly

Try running this instead:

run-parts /home/akya/.anacron/cron.hourly

I have nothing in /home/akya/.anacron/cron.hourly my scripts are in daily, weekly and monthly. I think what that guide intends the process to be is cron runs anacron hourly and then anacron takes care of when to execute the commands. I need anacron as computer isn’t always on so I dont need a exact time scheduler. So I tried to run

run-parts /home/akya/.anacron/cron.daily

and that works but I need cron to run it.