Need help to fix emergency mode after increasing disk size (VM in proxmox)

As title, I really need your help.

My Proxmox system is set up on a single physical machine running 4 LXCs and a virtual machine (endeavouros OS with KDE), Proxmox is installed on a separate 256GB SSD and everything else is on a 12TB mechanical hard disk.
I’m new to both proxmox and linux (Linux 6month、Proxmox 1month)

Originally I had given the endeavouros VM 1000G of space to use, and today I wanted to expand the capacity of this VM in order to back up my main computer’s files.


  1. I didn’t shutup the VM at first, and in the WEB GUI of Proxmox, I selected the hard disk in the Hardware tab of the VM and chose “Resize”, then adjusted it to 5TB.
    Then restarted the VM and found the available partitions increased, I thought I should also extend the file system to the unused partitions in the VM, so far so good.

  2. So I went inside the VM, but I didn’t use the command, I installed “KDE’s partition manager tool” and used manager’s GUI, entered the size I wanted to expand and chose “execute”, then it show the execution is failed, but I still tried to use different number to scale it up to test if the change was successful.

  3. I tried several times with different sizes and succeeded to see the increase in capacity in the file manager (999GB>1.9TB), then I continued to try to see if it could be scaled up to 5TB, but it didn’t work, I ran the command by partition manager tool to scale up the partition at least 5 times, but it failed, and that was the beginning of the disaster…

  4. After Step3, I restarted the VM and it failed to start.
    (I have the error msg snapshot)

When I follow the prompts to execute the following command
It returns the following result

fsck /dev/disk/by-uuid/cb52f685-4320-40c9-9a7c-4bb84f73e800
fsck from util-linux 2.39.1
e2fsck 1.47.0 (5-Feb-2023)
The filesystem size (according to the superblock) is 524288000 blocks The physical size of the device is 511705088 blocks Either the superblock or the partition table is likely to be corrupt! Abort?

After collecting some data, I tried the solution with the highest score
in this article
executed command

e2fsck -f /dev/disk/by-uuid/cb52f685-4320-40c9-9a7c-4bb84f73e800

But when I want resize2fs, system say command not found
By the way, lsblk also return command not found to me

So for now, I don’t know how to do, although I have a backup, I still hope that the system can restore whitout lose data.
I just want to increase disk size…

If you need other information plz tell me, I can provide it immediately as fast as I can.