Need help installing usb-printer

Hi all,

i have a canon TS3451 Pixma what i want to use over USB. I looked in the wiki-page (btw i like the wiki)

https://discovery.endeavouros.com/network/printers/2021/03/

and have all done what is said there except one cause i have budgie desktop. But if i want to print something, none of the applications i tried, e.g. Document Viewer, find the printer.

So me think i missed something to do but dont know what.

Edit:

[as@kiste ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 046a:0702 CHERRY Wireless Dongle
Bus 001 Device 004: ID 0408:5368 Quanta Computer, Inc. HP TrueVision HD Camera
Bus 001 Device 005: ID 04f3:0c00 Elan Microelectronics Corp. ELAN:ARM-M4
Bus 001 Device 006: ID 0bda:b00e Realtek Semiconductor Corp. Bluetooth Radio 
Bus 001 Device 007: ID 04a9:18b7 Canon, Inc. TS3400 series
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Edit2:

if i try to install the printer manually in cups i cant choose the TS3451 cause it is not offered in the scroll-down-menue :frowning:

Edit3:

Oh man, cannon only has a deb file for me. They also offer a source file but then i assume i have to compile it for AUR. Thats a bit to much for me at the moment

Edit4:

In this link the ts3451 is mentioned, but i dont know how to use this
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=canon-pixma-ts5055-complete

Edit5: well…

[as@kiste ~]$ sudo pacman -Syu cnijfilter2
[sudo] Passwort für as: 
:: Paketdatenbanken werden synchronisiert …
 endeavouros ist aktuell
 core ist aktuell
 extra                   7,9 MiB  3,95 MiB/s 00:02 [----------------------] 100%
 multilib ist aktuell
Fehler: Ziel nicht gefunden: cnijfilter2

Edit6: I really dont know what is going on

[as@kiste ~]$ lpinfo -v
network beh
network lpd
file cups-pdf:/
network ipps
network http
network socket
network https
network ipp
direct usb://Canon/TS3400%20series?serial=6969DA&interface=1
network smb

With

lpadmin -p ts3451 -E -v usb://Canon/TS3400%20series?serial=6969DA&interface=1

i managed to bring the printer into cups. Also changed some default entries in the cupsd.conf. Now it looks like this in cups

but the printjob is not printed by the printer, does not reach the printer. Any ideas?

I found the ppd for this printer “canonts3400.ppd” in the sourcefiles from the canon webpage. But if i install the printer over cups, it shows me “/usr/lib/cups/filter/cmdtocanonij3 missing”.

The cmdtocanonij3 is also in the source files, but have to be compiled with “make” me think. There are a lot of “.h” and a “makefile.am”

Can anyone guide me through the “make” process for that please? Thx.

LOL make install gives

“/usr/bin/ld: cannot find -lcnbpcnclapicom2”

Kranplätze müssen verdichtet werden! :roll_eyes:

yay -Ss canon ts
aur/r-ccp 1.2-9 (+0 0.00) 
    Significance Tests for Canonical Correlation Analysis (CCA)
aur/r-fccac 1.30.0-1 (+0 0.00) 
    functional Canonical Correlation Analysis to evaluate Covariance between nucleic acid sequencing datasets
aur/cnijfilter-ts7450series 6.10-1 (+0 0.00) 
    Canon IJ Printer Driver for Linux for Pixma 7450 series and other based on 6.10 version
aur/canon-pixma-g6000-complete 5.90-1 (+2 0.14) 
    Print Scan for Canon PIXMA series E3340 G5040 G5050 G5070 G6040 G6050 GM2050 TS3340 TS3350 TS3351 TS3352 TS3355 TS5340 TS5350 TS5351 TS5352 TS5353 TS6340 TS6350 TS6351 TS8340 TS8350 TS8351 TS8352
aur/canon-pixma-ts5055-complete 6.40-1 (+5 0.76) 
    cnijfilter2 scangearmp2 Print Scan for Canon MAXIFY PIXMA PIXUS series E200 E300 E3100 E3300 E3400 E4200 E4500 E460 E470 E480 G1020 G2020 G2060 G3000 G3010 G3020 G3060 G4000 G4010 G5000 G500 G5080 G6000 G600 G6080 G7000 G7080
aur/canon-ts9020 2.5.40-2 (+0 0.00) 
    Canon TS9020 MFC cups and scanner Drivers

something for you in there
start there,
also run the /.sh install script if you have the source files. (./sh in terminal I mean–right click it.–Also in sourcefiles there should be a README.
Can’t stick around this morning, but I hope this points you in the right direction.

yes, but tere is no ts34xx. Me think it is cause there is no cmdtocanonij3 in AUR and so no driver

In the “readme” Building “cmdtocanonij3”.
./autogen.sh
make
make install

all ok, but crash cause usr/bin/ld cant find lcnbpcnclapicom2

all you can do is install the TS pack then choose it from the add printer dialogue box–try the number directly below or directly above your number. That’s call a ‘fakeout’ and often it works.
you can right-click the .sh and start it in terminal if your DE gives that option or…
most of the time you have to change directory in terminal (cd) to the folder where your .sh is then try to run it.

edit: you will get nowhere with the .deb. as long as this was a targz source file you should be all right.

yes, i thought also about this hack if nothing else works. But meanwhile it bother me so i will first try to resolve the issue, try to make the cmdtocanonij3-source into a file :slightly_smiling_face: if i have success, then maybe cmdtocanonij3 can be moved into AUR. If i have no success, i will “check the hack”

1 Like

don’t give up on the targz. I do this for my brother printer all the time. half the time it won’t be like their instructions. it’s a PITA but you have the sourcefile. maybe you even have the ppd?

yes, i also found the ppd in the source. i installed it in cups and then this error with the missing cmdtocanonij3 in the filters came up.

The “hack” does not work. I tested some printer below ts3451 and some printer above. With all the print needs about 2 min per page (shown in cups), is send to the printer (the printer-light blinks), but nothing is printed. So back to “make cmdtocanonij3”…

I think the package in the AUR may work. USB is very easy. It should pick it up automatically when you browse print settings and click add from the start menu programs.

yay -S canon-pixma-g6000-complete

Edit: Hopefully you remove everything you have done prior before installing this package and trying it.

Thx for help :slight_smile: But it is like it is with all others: 2 minutes per page and then the printer doesnt print.

Me think it is definitely the thing with “cmdtocanonij3” what steer the inkjets of this printer in an different way than the “cmdtocanonij2” do it with all the AUR-listed printers.

Okay… I know i have this printer working before. I just couldn’t remember what package i used so here is the one i think worked. It does have this exact model listed as supported. TS3451

yay -S canon-pixma-ts5055-complete

Edit:

https://aur.archlinux.org/packages/canon-pixma-ts5055-complete

there is no ppd file

as@kiste ~]$ lpadmin: Druckertreiber sind veraltet und werden in einer zukünftigen Version von CUPS nicht mehr funktionieren.
lpadmin: cups-driverd failed to get PPD file - see error_log for details.

where can i find it?

Edit: Not sure if this will help you get it working. :thinking:

Thx for answering. I tried this source-driver at the beginning (no AUR package at Cannon). It includes a ppd for this printer. But show up an error “/usr/lib/cups/filter/cmdtocanonij3 missing”

The problem is that there is no cmdtocanonij3 in AUR :frowning: I tried to compile from the source but there was also an error “/usr/bin/ld: cannot find -lcnbpcnclapicom2”. That lcnbpcnclapicom2 also does not exist in AUR.

I ran the package build and at the end it shows this:

Final steps you have to take:
==>
==> Connect & turn on your printer
==>
==> Run command
==> cnijlgmon3
==>
==> This should give you the address of your printer.
==> Now you can register it with
==> sudo lpadmin -p TS5055 -m canonts5000.ppd -v -E
==>
==> How to scan:
==>
==> A ‘Cannon Scangear’ icon has been installed in your application menu.
==> Alternatively, run this command from the command line:
==> scangearmp2
==>

I don’t have a printer to hook up and test. But it does look like it built the package for the printer.

Edit: I also ran this package build which is the first one i mentioned.

yay -S canon-pixma-g6000-complete

It also completed and shows the same info at the end.

Edit: I’m pretty sure these should work for that printer.

1 Like

==> Räume auf…
Pakete werden geladen …
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (1) Neue Version Netto-Veränderung

canon-pixma-g6000-complete 5.90-1 11,10 MiB

Gesamtgröße der installierten Pakete: 11,10 MiB

:: Installation fortsetzen? [J/n] j
(1/1) Schlüssel im Schlüsselbund werden geprüft [----------------------] 100%
(1/1) Paket-Integrität wird überprüft [----------------------] 100%
(1/1) Paket-Dateien werden geladen [----------------------] 100%
(1/1) Auf Dateikonflikte wird geprüft [----------------------] 100%
:: Paketänderungen werden verarbeitet …
(1/1) Installiert wird canon-pixma-g6000-complete [----------------------] 100%

====================================================================================>
==>
==> Final steps you have to take:
==>
==> Connect & turn on your printer
==>
==> Run command
==> cnijlgmon3
==>

: Post-transaction-Hooks werden gestartet …
(1/2) Arming ConditionNeedsUpdate…
(2/2) Updating the desktop file MIME type cache…
[as@kiste ~]$ cnijlgmon3
[as@kiste ~]$ sudo lpadmin -p G6000 -m canong6000.ppd -v usb://Canon/TS3400%20series?serial=6969DA&interface=1 -E
[1] 19245
bash: -E: Kommando nicht gefunden.
[as@kiste ~]$ lpadmin: Druckertreiber sind veraltet und werden in einer zukünftigen Version von CUPS nicht mehr funktionieren.