Ncurses conflicting packages

I’m checking on this forum if anyone has posted this before, but I can’t find anything, so I guess I’m the first. I’ve been having this problem for a few hours now when I run the update:

pacman -Syu

:: Synchronizing package databases…
endeavouros is up to date
core is up to date
extra 8.3 MiB 5.54 MiB/s 00:01 [------------] 100%
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing ncurses (6.4_20230520-1) breaks dependency ‘ncurses=6.4’ required by lib32-ncurses

Am I the only one?
Thanks in advance.

Try resorting your mirrors.

I have tried using different mirrors, but the result does not change. To be on the safe side, I also ran an update with reflector, in this way:

reflector --age 12 --verbose -c AT -c FR -c DE -c IT -c CH -c NL --protocol https --sort rate --latest 8 --download-timeout 5 --save /etc/pacman.d/mirrorlist

Same error.

I see the issue. You don’t have multilib enabled in /etc/pacman.conf.

You probably accidentally disabled it when you merged the recent changes.

I think so (I deleted blank lines in the following output):

cat /etc/pacman.conf | grep -v “^#”

HoldPkg = pacman glibc
Architecture = auto
ParallelDownloads = 5
SigLevel = Required DatabaseOptional
LocalFileSigLevel = Optional
SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist
Include = /etc/pacman.d/mirrorlist
Include = /etc/pacman.d/mirrorlist

You should have this:

Include = /etc/pacman.d/mirrorlist

It is probably commented out.


Yes, you are right, thank you!
This was not mentioned as an intervention to be done on this web page:
Or maybe I made a mess while merging the files…

1 Like

It was likely this. It didn’t require any intervention but you probably merged the default state of multilib instead of keeping it enabled.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.