Names on local network do not resolve

I can’t get local network names to resolve. No matter what I try, I keep getting a Temporary Failure in Name Resolution error when I try to SSH the server (raspberrypi.local on my local network). I tried everything on this article ( already, and nothing helps.

I have Windows installed on the machine as well (duel boot) and there’s no issue on Windows (SSH to server works perfectly there). I can SSH to the IP address without issue on Endeavour… so it’s definitely something about the name not resolving.

I am at my wits’ end. Would appropriate any help you can offer :slight_smile:

Try following the recommendation in 2.1 here:

That should enable .local resolution.

I am using systemd-resolved. Shouldn’t that negate the need for Avahi?

systemd-resolved normally doesn’t require special configuration for mdns.

We don’t ship with that configured though. Are you sure you configured/enabled it correctly?

I assume something is amiss, but I can’t tell what’s wrong for the life of me.

Googled a lot of articles on this error, and followed the article I linked to to the letter.

OK. Solved it.

Needed to open port 5353 for UDP (explained under the mDNS section here

Thanks all :slight_smile:

Interestingly enough, this (5353 UDP) isn’t mentioned in any article on the topic that I found. Only in the Arch wiki page.