Name of the partition is not displayed in Thunar

Today I installed another HDD as a backup disk and entered it in fstab for mounting (noauto). Only one problem: I gave the partition a name with gparted, but it is not displayed in Thunar (sidebar). It only says Datenträger 1.7 TB. what can I do?

Exactly what type of parition are you trying to display in Thunar?

you can obtain what you want by directly editing /etc/fstab

or you can use Disks (package gnome-disk-utility) if you like GUIs more (like I do :P)


3 Likes

It’s a ext4-partition, mounted under /media/backup.

1 Like

See the solution provided by Nate and then attempt a reboot too. Occasionally, a live file structure name may not always populate as it should.

1 Like

I entered it manually in the fstab:

,x-gvfs-name=Backups

it works fine! Thanks for your help!

One more question: is it necessary to set the check option in fstab for a partition that should not be mounted automatically at boot? I have set this backup partition to 0:

UUID=dd3668ed-5ff8-48ea-b33a-023da89b4ae3    /media/Backup   ext4     defaults,noauto,x-gvfs-show,x-gvfs-name=Backup    0      0