My WIFI Stopped Working Suddenly

I had my pc on and I came back to it and it was frozen I restarted it and when it turned on it wouldn’t automatically connect to the internet and the wifi manager on the bottom right disappeared and I am not able to use any system updates because it won’t connect to the internet I have no idea what happen since it happened out of no where.

can you give some hardware information with

inxi -Fz


What DE are you using? Are you using network manager? Can you connect to yhe internet via ethernet cable?

What does

sudo systemctl status NetworkManager.service


Unfortunately I have to manually type out everything

inxi -fz shows

Info: 6-core model: Intel Core i5-9600kf bits:64 type: NCP cache:
L2: 1.5 MiB
Speed (MHz): avg: 2733 min/max: 800/4600 cores: 1: 800 2: 3700 3: 3700 4: 3700 5: 800 6:3700
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 bmil bmil2 bts clflush clflushopt cmov constant_tsc cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est fl6c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr

The DE is xfce4
I have no idea what the network manager is on here so I am not entirely sure
The ethernet cable I have is too short to reach

sudo systemctl status NetworkManager.service gives

NetworkManager.service = Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
Active: active (running) since Fri 2023-04-21 20:32:50 PDT; 21h ago
Docs: man:NetworkManager(8)
Main PID: 541 (NetworkManager
Tasks: 4 (limit: 19058
Memory: 19.9M
CPU: 991ms
CGroup: /system.slice/NetworkManager.service
541 /usr/bin/NetWorkManager --no-daemon

Apr 21 20:32:50 Fumo NetworkManager[541]: [1682134370.8759] ovsdb: disconnected from ovsdb
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8760] device (lo): state change:
disconnected → prepare (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8761] device (lo): state change: prepare → config (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8762] device (lo): state change: config → ip-config (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8769] device (lo): state change: ip-config → ip-check (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8801] device (lo): state change: ipcheck → secondaries (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8802] device (lo): state change: secondaries → activated (reason ‘none’, sys-iface-state: ‘external’)
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134370.8805] device (lo): Activation: successful, device activated.
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134376.8653] manager: startup complete
Apr 21 20:32:50 Fumo NetworkMaager[541]: [1682134494.4108] agent-manager: agent[4da58117b8acc6c2,:1.49/org.freedesktop.nm-applet/1000]: agent registered

That’s it a lot to manually type sorry if there is mistakes

Indeed that is a lot to type…
Maybe you could copy outputs if we need more in a text file to your phone or a usb stick and from there to here.

Seems like Network Manager is activated. So, if just the panel icon is missing, try if it appears when you open a terminal and execute

sudo nm-applet

Leave the terminal window open and see if the applet is displayed.

Doesn’t Xfce have network settings somewhere as GUI?

Also you should verify that WiFi is not hard or soft blocked with

rfkill list

No need to type the output here, just check that it says “no” for hard blocked and soft blocked for your wifi.

If it’s not blocked but the nm-applet still doesn’t appear, you can also try and connect to wifi using

 nmcli device wifi connect *SSID_or_BSSID* password *password*

The marked parts of course need to be replaced with your SSID and password.

See also:

Edit: it would have been inxi -Fz, so with a capital F. There should also your wifi device be listed.

Please note that

inxi -fz

produces very different listing compared to

inxi -Fz

Edit: now I noticed @PigOfDestiny already mentioned this…

1 Like

That would be commands like this:

rfkill list >> rfkill.txt
inxi -Fz >> inxi.txt

@ FilledWithNothing
The generated text files can then be found in the home folder.

1 Like


I did the inxi -Fz command this time it gave this

  Kernel: 6.2.11-arch1-1 arch: x86_64 bits: 64 Desktop: Xfce v: 4.18.1
    Distro: EndeavourOS
  Type: Desktop Mobo: ASUSTeK model: PRIME Z390-P v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2417
    date: 06/03/2019
  Info: 6-core model: Intel Core i5-9600KF bits: 64 type: MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 1766 min/max: 800/4600 cores: 1: 800 2: 800 3: 800
    4: 3700 5: 3700 6: 800
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 530.41.03
  Display: x11 server: v: driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,vesa gpu: nvidia resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.2.11-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.69 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp5s0 state: down mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 2.04 TiB used: 192.35 GiB (9.2%)
  ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0A-00JH30
    size: 223.58 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
  ID-3: /dev/sdc type: USB vendor: Generic model: Flash Disk size: 503.8 MiB
  ID-1: / size: 218.51 GiB used: 192.35 GiB (88.0%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 511 MiB used: 304 KiB (0.1%) fs: vfat dev: /dev/sda1
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) file: /swapfile-1
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 237 Uptime: 1d 19h 9m Memory: 15.53 GiB used: 2.09 GiB (13.4%)
  Shell: Bash inxi: 3.3.26

The sudo nm-applet command gives this

(nm-applet:97423):  Gtk-WARNING **:  15:55:00.241:  Theme parsing error: gtk.css:5822:26: '-shadow' is not a valid color name
(nm-applet:97423):  Gtk-WARNING **:  15:55:00.241:  Theme parsing error: gtk.css:5825:14: not a number
(nm-applet:97423):  Gtk-WARNING **:  15:55:00.241:  Theme parsing error: gtk.css:5826:13: not a number
(nm-applet:97423):  Gtk-WARNING **:  15:55:00.241:  Theme parsing error: gtk.css:5827:11: Expected a length

rfkill list gives this

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Using nmcli device wifi connect SSID_or_BSSID password password tells me

No Wi-Fi device found.

I tried looking for the gui for network setting but it looks like it doesn’t help besides putting in password and ssid for network?

1 Like


For better readability, please format the output you paste into your posts.

Just highlight the text and press Ctrl-E.


1 Like

The WiFi is AC-3168 and should be using iwlwifi module.

Was it using that previously and it changed to something else suddenly or is this something I need to install?

It’s a kernel module. You can try to unload it and load it.

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Seems to have done nothing

When it quite working had you updated the kernel?

Yes it was working after an update but I left my computer alone for a while and suddenly wifi was gone

I take it you have rebooted it since then? Are you currently running it on Etherent?

Yes I have rebooted it because what happened was when the wifi was gone my computer was frozen at the same time and after rebooting it I noticed the wifi was gone and no it’s not running on ethernet since my ethernet cable is too short

Are you not able to connect it then and try to run an update?

Endeavour sometimes does not detect the wifi on cold boot (from powered down state). The fix (for me) is to boot into Windows first then reboot again. I tried all the suggestions on archwiki, this forum, etc. I tried booting into other linuxes as well when this happens to no avail. Other option was to power down again, wait several seconds then reboot and repeat several times until the wifi is seen. Powering on/off frequently is not good for electronics.

Makes no sense. Maybe it’s motherboard specific and somehow the Windows drivers for the motherboard chipsets wake up the wifi.