My touchpad is 'working' but KDE settings says it is 'not found'

I have a Lenovo Thinkpad X1 Nano running Plasma 6.0.3 and kernel 6.8.2

The trackpad has been working and ‘found’ up until last week. I noticed the scroll direction was back to the default when swiping up or down, so I want to go back into the setting and invert it again.

However, when I go to the Trackpad settings in KDE, I get the message “Trackpad not found”

Any ideas on how to “find” it (or at least get my scrolling fixed again)?

Thank you!


Are you on X11 or Wayland?

Currently on X11

Can you post the output of

$ xinput list

xinput list  :heavy_check_mark:  took 23s   at 07:51:33 
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ELAN0670:00 04F3:3150 Mouse id=10 [slave pointer (2)]
⎜ ↳ TPPS/2 Elan TrackPoint id=15 [slave pointer (2)]
⎜ ↳ ELAN0670:00 04F3:3150 Touchpad id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Lid Switch id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ sof-hda-dsp Headphone id=12 [slave keyboard (3)]
↳ Intel HID events id=13 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]
↳ ThinkPad Extra Buttons id=16 [slave keyboard (3)]

It appears that your trackpad is indeed detected. This smells like a bug in KDE’s GUI. For now, try to configure the trackpad using an xorg configuration file first.

Create a file called /etc/X11/xorg.conf.d/trackpad.conf with the following contents:

Section "InputClass"
    Identifier "Touchpad Custom Configurations"
    MatchIsTouchpad "on"
    Option "NaturalScrolling" "true"

Reboot and test.

P/S: I’m not sure if reverse scrolling is what you want (it was unclear from the original post); if it isn’t, just set NaturalScrolling to false instead of true.

Thank you. For some reason I was getting a loop trying to log back in to the X11 session, so I logged in using Wayland and the touchpad is detected there with the KDE settings!

Probably due to the Xorg config file you just added. If you still want to test, you can try to modify the file contents to:

Section "InputClass"
    Identifier "Trackpoint Custom Configurations"
    MatchProduct "ELAN0670:00 04F3:3150"
    Driver "libinput"
    Option "NaturalScrolling" "true"

Thank you! I’ll make the edit and give that a try

Works great. Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.