My Samba Network Education [Solved]

I want to apologize for the post awhile back that I had pulled, I was not in a good place and I am sorry for the post.
With that said this is more of a Information post than anything. If I have it in the wrong place Mod’s Please move it where you want it. Thanks You!

Well what can I say about samba. It is a new dog that this old 66 year old dog had to re learn… :slight_smile:
With that said, this is my lesson learned. I hope this helps someone else!
I finally got my Samba / Network sorted out. I know after my last post I started to think about my issue with samba yesterday and that lead to doing… Lol
With that said, I kept saying my samba config worked for years until Jan 2020. After fighting with this issue for months I had enough! I was going to Fix this Problem!!!

My Config was setup for a NT / Windows network. Work fine until January when Arch and Samba made changes in 2020. I’m guessing…
The other day I was looking for a file on a old backup storage file drive and I found my master copy of the smb.conf file from years ago. I was looking at it and noticed that there were no “protocol” statement. Years ago samba defaulted to SMB1 and or NT1 with no statements needed.

All my systems were set up this way. The Arch system I was messing with had all these “Min or Max or Core” stuff I was adding and still nothing was working on 2 of the Arch systems I was using for testing.
The 5 Debian based systems was kinda working mostly, by saying that, the Network Folder did not show anything but I could type the smb:// 192 address and get to the other Debian systems until last month.

Anyway back to this old smb.conf file. After looking at it for about a hour and thinking, I decided to shut down everything and just work on 2 systems, a Arch and Mint system until I get them working together and then add another one and so on. My Ubuntu Server was the Anchor Point.
After 15 plus hours of testing I have a fully working Network for Arch, MX, Mint, Ubuntu.
After a bunch of hoops I found what works for me, right or wrong. I also found a Samba setup Text file on the net by “Samba, by joekamprad” This file was designed for Arch but will work for Debian based ISO’s.

What I found that work for me is this:

workgroup = STARFLEET
passdb backend - tdbsam
security = user
usershare owner only = false
client min protocol = NT1
server min protocol = NT1
name resolve order = bcast host lmhosts wins
usershare path = /var/lib/samba/usershare
wins support = yes

This works and I have my Network Folders back in Nemo and all the Network shares for all the computers are there like they use to be. :smiley:
I know someone out there is going to yell “SMB2”! While yes I could use it I had 2 system that complained (Older Samba) about it so I stuck with NT1. It works for now and if I have issues later then I will change…

Like I said I ran NT servers for years for my customers and I know what to do then. This is Now, and Samba removing support for SMB1 had screwed up the works as “defaults” did not work either. Had to unlearn Sambas old ways… Lol
Anyway, there ya have it! This old Dog Won Again… Lol
Once again I’m sorry for the large post!


Happy to see you’ve solved your problem. May I suggest you add your solution to your request-thread?

Thank You @Barqu for the reminder! I totally spaced it… :rocket: :slight_smile:

@bescott9944 is not really a Newbie to go in the older post ! but I think move it to the INSTALL/APPLICATION could be better !

Are you ok with this @bescott9944 ?

At the end, we all dance the SAMBA cause all this is a story of Licence, I spoke about it here [Warning] Samba 4.11.3-3 pushed on archlinux extra repository is broken

@FLVAL, I had read so much stuff in the last few weeks I totally forgot your post. The other day I remembered something about SMB1 just couldn’t remember what… Could not see the forest for the tree’s thing… Old Ya Know…:slight_smile:
I think my biggest issue was I was trying to do the whole network and not just getting one thing to work on 2 computers and forget about the rest of them. Sometimes Old Dogs have a hard time learning new Tricks… Lol
As For Moving the post @FLVAL I am ok with that. I just don’t know how…
Thank you …

Thanks @bescott9944 to be ok with that, I will move it.

Sometimes Old Dogs have a hard time learning new Tricks… Lol

Until the machines works, there is no old or young time to bite :wink:

EDIT: I had to move it in General system/Installation cause after checking the Application category it says :


1 Like

@FLVAL, Thank you for your help! Love this Forum! Best in the world! :ringer_planet:

1 Like

I know how you feel, I have been researching SAMBA also.

Archlinux always has the latest and greatest, as such they are offering SAMBA v4.

In my research, I have found that they recommend the following setting for SAMBA v4 in the Archlinux device’s smb.conf under [global ]

ntlm auth = true

I’m not really sure what this does, but I believe this makes things more compatible when other devices on the network are smb v2 or v3. Since you have this working, I offer this as a FYI.



1 Like

Thank you @Pudge for the FYI, it is much appreciated.
Yes I believe the Samba Saga is going to be a ongoing issue in Arch for sure. Like you said;

The Debian distros like MX, Mint, Ubuntu are indeed still using older versions of Samba and that also plays in the the equation. That is one of the consideration I weighed in using NT1 everyone was happy with it. The Samba Man Page and Smb.Conf Man pages, made it sound like everyone should just use SMB3 but It did not work for me at this time with all the versions of Samba I have going in the distros…

While Arch on the other hand does make life hard at times, it does keep us on our toes… Lol

I always through in the towel and then pick it up and give it a go again… :slight_smile:
I’m that much like @ricklinux, he is the sameway… :smiley:

So I really never give up with Arch I just find a way to fix it “My Way”, Like the song!
I have made note of you suggestion and I will look into it later, this week as I am all Sambaed out… :slight_smile:
I know I will be revisiting this sometime in the future, just not to soon Please… Lol
Take care and thanks again for the help as always!

1 Like