My old intel i3 380m doesn't run code,discord,chromium unless i add --disable-gpu

im new in linux but i encounter this error that my apps (those three) will go blank and if i use terminal with --verbose it will show error

#version 100

precision mediump float;
precision mediump sampler2D;
uniform sampler2D uTextureSampler_0_S0;
varying highp vec2 vTextureCoords_S0;
varying highp float vTexIndex_S0;
varying mediump vec4 vinColor_S0;
void main() {
    mediump vec4 outputColor_S0;
    outputColor_S0 = vinColor_S0;
    mediump vec4 texColor;
        texColor = texture2D(uTextureSampler_0_S0, vTextureCoords_S0, -0.5).xxxx;
    mediump vec4 outputCoverage_S0 = texColor;
        gl_FragColor = outputColor_S0 * outputCoverage_S0;

0:1(10): error: GLSL 4.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES

this is from discord, but and the end of the line will exist those Errors:
0:1(10): error: GLSL 4.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES

it will run fine with --disable-gpu.
what is the problem, do i mess up the update or something, i tried using another distro (manjaro) it was run fine without --disable-gpu.
here is my spec

  Device-1: Intel Core Processor Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010 ports:
    active: LVDS-1 empty: VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0046
    class-ID: 0300
  Device-2: Microdia Laptop_Integrated_Webcam_0.3M driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.4:4
    chip-ID: 0c45:6422 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: sway v: 1.8.1 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: 1
  Monitor-1: LVDS-1 model: InnoLux Display 0x0014 built: 2010 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 scale: 1 size: 309x174mm (12.17x6.85")
    diag: 358mm (14.1") ratio: 16:9 modes: 1366x768
  API: OpenGL v: 4.5 Mesa 23.1.2 renderer: Mesa Intel HD Graphics (ILK)
    direct-render: Yes

i tried this solution but not avail

i tried to run sudo startx – :2 vt2 -extension GLX then in gave me an error

Fatal server error:
(EE) AddScreen/ScreenInit failed for driver 0
Please consult the The X.Org Foundation support 
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.2.log" for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

in the log

this is the output for glxinfo | grep OpenGL

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics (ILK)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 23.1.2
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 23.1.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 23.1.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:

It’s trying to use a GLSL (the thing used for shaders on OpenGL) which your GPU doesn’t support, which is strange, since my craptop, which supports up to 4.4 on Winblows, and 4.6 on :enos: , and Diskord launches fine.

Do you have xf86-video-intel installed?

i don’t have , i tried to install it but it still give me an error, but its a different error

Something is wrong with your X Server. Except it isn’t, since you are using Wayland. In that case you shouldn’t use xf86-video-intel. (at least I’m told)

Electron probably doesn’t support Wayland yet. Electron is a way for lazy “app” developers to make an “app” that just goes to a hardcoded website.

Okay, it’s just a minor inconvenience, as long as I can open the app, thanks for the reply

I set the overide GL something version 4.5 in .zshrc sometimes ago and forgot about it​:person_facepalming:.
Just revert it and ran fine again

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.