My mic detected as speaker

My mic has two black bands are on it.

When i connect my mic, it is detected as speaker. I would like to use it as a mic.

Thanks in advance!

System info:

System:    Kernel: 5.13.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 
           tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Desktop System: SAMSUNG product: 500T8A/500S8A/500T9A/500S9A v: CAAAAAAA serial: <filter> 
           Chassis: type: 3 serial: <filter> 
           Mobo: SAMSUNG model: SAMSUNG_DT_DM500T8A v: SAMSUNG_SW_REVISION_12345+0.0.0000 serial: <filter> 
           UEFI: American Megatrends v: P07OEC.042.200605.CL date: 06/05/2020 
CPU:       Info: Dual Core model: Intel Pentium Gold G5400 bits: 64 type: MT MCP arch: Kaby Lake note: check 
           rev: A cache: L2: 4 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 29608 
           Speed: 2243 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 2243 2: 2273 3: 997 4: 1817 
Graphics:  Device-1: Intel CoffeeLake-S GT1 [UHD Graphics 610] vendor: Samsung Co driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:3e90 
           Display: x11 server: 1.20.13 compositor: kwin_x11 driver: loaded: intel 
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Samsung Co driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a348 
           Sound Server-1: ALSA v: k5.13.12-arch1-1 running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 4000 bus-ID: 00:14.3 
           chip-ID: 8086:a370 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co driver: r8169 
           v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           IF-ID-1: tap0 state: down mac: <filter> 
           IF-ID-2: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 
           bus-ID: 1-14:4 chip-ID: 8087:0aaa 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 1.14 TiB used: 43.47 GiB (3.7%) 
           ID-1: /dev/sda vendor: Imation model: M.2 SATA3 256GB SSD V531 size: 238.47 GiB speed: 6.0 Gb/s 
           serial: <filter> 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-35WN4A0 size: 931.51 GiB speed: 6.0 Gb/s 
           serial: <filter> 
Partition: ID-1: / size: 233.17 GiB used: 43.47 GiB (18.6%) fs: ext4 dev: /dev/dm-0 
           mapped: luks-52d52d95-c80a-4b7b-98d9-6c55a17578fd 
           ID-2: /boot/efi size: 511 MiB used: 448 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: file size: 512 MiB used: 63.8 MiB (12.5%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A

Do you know how to add a kernel parameter to the default grub file and update grub?

sudo nano /etc/default/grub

add to the end of the default grub command line


Example: GRUB_CMDLINE_LINUX_DEFAULT=“quiet loglevel=3 snd_hda_intel.dmic_detect=0”)

Then save with

ctrl + o enter

close with

ctrl + x

Then update grub

sudo grub-mkconfig -o /boot/grub/grub.cfg


This may or may not work for your issue but worth a try. If it doesn’t work. Just remove what you added the same way and update grub again.

Is audio working currently? Some of these Intel audio chips require sof-firmware also in order to work. I think this may be one of them. Maybe?

bus-ID: 00:1f.3 chip-ID: 8086:a348 

Edit: Other then this you’ll have to look at the Arch wiki


Thank you so much! Editing /etc/pulse/ worked.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.