My machine freezes randomly

Hello there,
I have HP G7 250 with i5-1035G1 and iris and using linux-zen kernel with xfce4.
My machine was freezing randomly with no chances to use tty while freezing. It sometimes worked for days without any problem and sometimes froze after 2 up time hours.
I used this in /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "uxa"
        Option "TearFree" "true"
        Option "NoAccel" "True"
        Option "DRI" "False"

and added i915.enable_psr=0 to kernel command, and my problem have disappeared till now.
But yesterday, I tried to copy a 3GB file to my android phone by usb cable, and it did freeze while copying, then I tried to extract it while my phone was connected but it froze again, and when my phone was disconnected it extracted it normally!
Note: xf86-video-intel is installed and when i tried to get rid of it Xorg didnt start at all.
Thanks in advance, and I wish there is a way can help me with it. And I have another HP machine with AMD Radeon which is working properly.

give some specs and journal…

journalctl --since "10 minutes ago"

could be helpfull after reboot from a freeze


Does this happen on all kernels? Has it been happening as long as you’ve been using this machine or does it seem to be specific to recent versions of the kernel?

Random freezes are almost 100% of the time hardware related.

If you’re saying that you suspect USB is a factor then you could check with different cables, and also for “runaway” ACPI interrupts with

grep enabled /sys/firmware/acpi/interrupts/*

and look for one (e.g. gpe03) that has a (very) large number. Keep in mind that this won’t show anything interesting unless there is a problem currently happening, so you can’t just run the command once and then ask “oh, does this look OK?”

If you see one with a (very) large number then you can try disabling or masking that interrupt; this will let the OS ignore that hardware trigger.

Also, try with some different kernels. :joy:

I had the same problem, took me 9 months to figure out that my cpu was failing.
Maybe a hardware problem?


1 Like

That didnt happen again, I’ll when it happen.

I faced it on ZEN kernel, I didnt try using another kernel, but that happens on every version.

Should I do it after freezing or not?