My ethernet interface (r8168) disappears on every kernel that is not 6.8.9

I am in despair at this point. A few months ago, every kernel update made my network driver lowkey disappear, or at least there was no ethernet interface recognized. It wasnt just shut down, it was literally like a dead cable, the router didnt even recognize it as plugged in.

I fixed it temporary by just downgrading the kernel, although every other kernel besides 6.8.9-arch1-2 and linux-headers 6.7.1.arch1-1 produced the same problem. This was the only combination of kernel and linux-headers I could install via downgrade that made the ethernet work.

Now, I started having problems with nvidia, and on nouveou a lot of games wont run, so I would like to finally fix this and update my kernel to the newest version without my network card saying bye-bye.

lspci -v gives me that regarding my network driver:

1b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet Controller (rev 15)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7a36
	Flags: bus master, fast devsel, latency 0, IRQ 29, IOMMU group 12
	I/O ports at f000 [size=256]
	Memory at fd504000 (64-bit, non-prefetchable) [size=4K]
	Memory at fd500000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8168
	Kernel modules: r8169, r8168

I have seen a few similar problems with r8168 in this forum, but the solution always was using linux-lts. I also tried using r8168-dkms. For me, all of these just lead to the old problem, a non existent ethernet interface :frowning:

Any tips on how I could make progress in fixing this? :sob:

Have you tried:

4 aur/r8168-dkms 8.053.00-2 (+25 0.56) 
    A kernel module for Realtek 8168 network cards (DKMS version)

You will probably have to blacklist the r8169 driver as well.

I tried r8168-dkms, it just replaced r8168. Blacklisting should not matter until I try to update, should it?

8169 is in the kernel, so yes, I would black list it.

1 Like

the build/package do blacklist r8 169 already.

But with the removal of the r8168 package for the default arch kernel, from the repository there is no working r8168 package as far as i know… only the one for LTS kernel is left at the repo.
And the r8168 modules are supporting the same cards as the newer r8169 shipped with the kernel.
So first make sure your device is really not working with r8169 module.

sudo rmmod r8168
sudo modprobe r8169
sudo systemctl restart NetworkManager

And show yay -Qs r8168

1 Like

I think @xircon is onto something, when I change the kernel to linux-lts, the network driver really changes to r8169. I wrote

blacklist r8169

into /etc/modprobe.d/blacklist.conf and installed r8168-dkms from the aur.

rmmod and modprobe disconnected me from the local network and reconnected me again. The output of yay -Qs r8168 now is:

local/r8168-dkms 8.053.00-2
A kernel module for Realtek 8168 network cards (DKMS version)

Although this is after installing r8168-dkms, as recommended before.

Does this help? I will try to reboot now once more, and see if linux-lts finds a network card with the dkms driver and the blacklist.
EDIT: The driver was still r8169, but running modprobe r8169 gave me a connection on linux-lts. This is a huge progress :sob: thank you so much already guys

as i said the r8169 should support most of the chipsets… the difference to the r8168 is only about different features.

I dont know why or how, but returning to the current linux kernel (6.9.6-arch1-1) with r8169-dkms and disabling r8169 with modprobe fixed everything. Even after rebooting the network is there again!

I changed to nvidia drivers and all my game-problems also disappeard. Thank you so so much guys <3

r8168-dkms i bet?

You checked with inxi -Naz ?

as of here it looked like the kernel shipped default is working for you.
The issue could simply be caused all the time by r8168 packages installed causing to balcklist r8169 and as of r8168 builds are broken your network device was not working.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.