My epson scanner cannot scan by adf more than one page

Hi everybody,

This is my first post in here because I just have installed Endeavouros recently, so please forgive my mistakes if there are any.
The problem is, I have multi-function printer Epson L565 and I have installed epsonscan2, and it is able to scan by ADF of course. But just one page. I mean, if I put several document in the ADF, it will only scan one document only, and the rest is taken out from ADF. I have tried some sane-based app like simple-scan, gscan2pdf, etc it is always the same.
Is there a way to fix this?

Thanks in advance.

Hi and welcome to the forum.

I don’t have an Epson, but I had a Brother Multifunction Printer with an ADF. As far as I remember I was not able to select a scan “source” like ADF or the flat pane for a single page. I just could invoke the scan from within sane software same as the “Scan” button on the printer itself. The printer had a sensor with preference for the ADF. So whenever there is paper being detected it pulled ALL pages until empty. If no paper in ADF it scanned one page from the flat pane.

But the printer is 10 years + so things might have changed.

Does the printer scan all pages from ADF if you start the scan from printer via button?

Edit: found this Video with same problem (the guy changed sth. on the printer itself, so may be it works with Linux as well…) →

1 Like

thanks for answering Peter, but the problem is still there.

when I scan many papers from ADF, it pulls one paper only until scanning that one page is finished, then the printer/scanner panel says “Taking out papers” and the rest of document is pulled into the ADF but no scanning, it just taking out papers like the panel said. So it only scans one page. And I cannot scan via button in Eos, maybe it’s just for Windows?

Once I tried scanning with Windows it works just I expected, pages pulled one by one and the app scanned. So I want to be able to do the same with Eos, if possible.

I checked the video you mentioned, I think it’s Windows solution, I cannot apply it to Eos as I cannot scan via button.

Just another guess: you can try xsane as frontend as it is more capable as other scanner software (ugly interface but more options)

From the page I saw that many Epson printer/scanners are supported by the sane-epson2 package.

But I have little hope that these are better than the package provided by Epson itself…

But worth a try.

1 Like

Sadly, I have tried xsane too and failed.

One app that works in linux is just VueScan but it has watermark and I must be premium to remove that.

Maybe is there any configuration in scanner that I’m missing?

Just to check, have you tried using Skanpage from KDE, or simplescan/Document Scanner from GNOME?

1 Like

yes I have, simple-scan, skanlite, skanpage, xsane, gscan2pdf, all of sane-based scanner app I have tried them (I use XFCE btw). And they just scan one page.
In case of simple-scan, I often get error segmentation fault(core dumped) after my first scan and it doesn’t scan.

So if VueScan works the it’s an issue with sane. Any frontend will bring the same result.

Checking the sane project page again I found a link to an external project site here - if you search that page for l565 you find a link to that repository here: your scanner/printer is directly mentioned in README.

Reading quickly through that doc it seems as if this driver wraps sth. around epsons native drivers. Worth a try. Sane project reports L565 as “Good” wich is not the best ranking. Might be that at this point in time there’s no solution for your scan problem… :confused:

1 Like

I have tried utsushi too, I installed via pacman, the package is in extra/imagescan and I run utsushi from terminal.
It scanned and I checked via Thunar File Manager it created the .pdf file, but then I got an error invalid call to _pdf_::writer::write (object&) and then that .pdf file vanished.