My EOS Journey Diary

:stars: Stardate: -300554.75038051757 :stars:

Hello Fronds!

I have been tinkering with :enos: and here is what I have accomplished since yesterday:

  • Successfully connected WiFi!
  • I was partially able to connect our Canon MF267dw printer (yay!) yet it won’t print (boo!). The printer is recognized and titled as Canon MF260 Series UFRII LT. I have no clue why it is not printing. Le sigh.
  • I started on the road to installing Battlenet…that’s in another thread. :laughing:

This morning, I found an orphaned AUR package and I deleted that.

The two challenges to overcome will be the printer and Battlenet.

Will RoRo win against these challenges?

Stay tuned. :tv:

Thanks for reading!

P.S. How in the baked beans do I install a .tar.gz in :enos:? I have the Canon printer driver downloaded from their site yet I do not know how to install it. The file is in my Downloads folder.

Is it a arch package?
Then you can install it with

sudo pacman -U package.tar.gz

I’m not sure, I found the driver on the official Canon support page. See HERE and scroll all the way to the Drivers & Download section.

Is the connection to the printer wireless? If so, could be a firewall issue.

Yes, it is a wireless printer.

There’s a number of different elements to printer troubleshooting…

Two obvious ones are:

  • You say that your computer can see the printer (as Canon MF260 Series UFRII LT). Does the screen on the printer also show that it is connected?
  • Try turning off the firewall, and then try to print a page on the printer

Also, you could try installing this printer driver from the AUR

yay -S cnrdrvcups-lb

pacman -Q | grep cups

This will tell you if the cups printer server is installed. If installed:
systemctl status cups
if it says cups is inactive
systemctl enable cups
systemctl start cups

When you get cups installed, enabled, and active, see if the cups server is working
In Firefox (or other browser) enter in the url address bar

This should bring up the cups server. If it doesn’t there is something wrong with cups
click on the "Administration " tab, then “Add printer” enter root for the user and root’s password.

It will then scan and give a report on available printers. If it finds your printer, and you have the driver from the AUR installed, finish installing the printer.



@r0ckhopper @Pudge

Update on printer situation.

  • Re: the firewall. The firewall was off and still no go on printing.
  • I attempted to install the driver tar.gz from the Canon website and terminal stated this:

error: missing package metadata in linux-UFRII-drv-v550-us-00.tar.gz
error: ‘linux-UFRII-drv-v550-us-00.tar.gz’: invalid or corrupted package

  • Pudge, I did everything you suggested. Still no go.

I even used the Printer Settings - localhost GUI, found the printer, attempted to print a test page, and the printer would blink with activity then stop. :frowning:

When I check the Document Print Status, it states status as pending.

And no joy with the AUR package ?


I ended up wiping out my SSD and restarting all from scratch with :enos_flag:,

I am putting my system information for a reference.

The result of using the inxi command:

  • CPU: dual core Intel Core i5-7200U (-MT MCP-)
  • speed/min/max: 3100/400/3100 MHz Kernel: 5.18.3-arch1-1 x86_64 Up: 52m
  • Mem: 2823.0/7818.8 MiB (36.1%) Storage: 238.47 GiB (3.8% used) Procs: 210
  • Shell: Bash inxi: 3.3.18
  • VGA Controller: VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02) (prog-if 00 [VGA controller])
  • 3D controller: NVIDIA Corporation GM107 [GeForce 940MX] (rev a2)
  • Audio device: NVIDIA Corporation GM107 High Definition Audio Controller [GeForce 940MX] (rev a1)

CPU: Intel i5-7200U (4) @ 3.100GHz
GPU: Intel HD Graphics 620
Memory: 2726MiB / 7818MiB

Hmmm…so my notebook has dual GPU. :thinking:

This may be the reason why I need to figure out how to make NVDIA my main GPU when running games.

@r0ckhopper Also, I have added CUPS in the re-install from the live USB. I’ll let you know if I can install the printer this time.

1 Like

I haven’t updated in a hot minute.

Let’s me correct this error!

Here are bullet points (cuz we live in a TL:DR world):

  • I created a standard user for my notebook and begrudgingly use it because this is the right thing to do.
  • I have decided to table trying to get Heroes of the Storm to work and took the easy path…I play games on Steam with no issues.
  • My printer will not connect. I have attempted everything I know and researched and a big nopers.
  • My Bluetooth speaker will sporadically disconnect and I’m not sure why. :thinking:
  • I downloaded Librewolf, adding Firefox add-ons, and now it will crash once and awhile. :thinking: Oh well…back to Firefox.