My endeavour os boot entry is now not in the boot menu

My boot menu had efi entries like ubuntu , windows boot manager , linpus lite(Deepin’s entry name). and SATA HDD.
And I had EFI HARDDRIVE entry before but it is now not there.
Today I plugged my usb(To copy some files) in and booted my pc.But endeavour os efi boot entry is not up there!:frowning:
And deepin’s boot entry linpuslite named entries are present more than 5.
Can anyone explained what happened.
"Sorry I typed in a hurry.So if there is any mistake,apologize

The following info might be of help for those who could help you:

sudo parted -l

efibootmgr -v

Copy-paste the terminal output in your reply, highlight it and click on </> to format.


Unfortunately i cannot login to linux.
i booted the deepin and ran update-grub and endeavour was shown and updated on grub.
But when i tried to boot that it fails.
i tried fallback thing also.

You could run those commands in Deepin.

BTW deepin is so sluggish, isn’t there any other way to solve?
The eos is installed as uefi in partition (hd0,gpt23)

If you need help with the current issue stated in your OP, please post the requested commands.
You could use your EnOS installer usb.


inxi -Fz

1 Like

Read this article and follow the instructions.


You can boot from deepin, right?
Can you show the contents of file /boot/grub/grub.cfg on deepin?

Ok I solved this problem.
And I got back my endeavour os.
What I did was entering the grub command line and booted the endeavour os kernel and after booting i run sudo grub-install and update-grub.
So everything fixed.
I did something like the below code.

set root=(hd0,5)
linux (hd0,5)/boot/vmlinuz…
initrd (hd0,5)/boot/initramfs…m

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.