My continuing woes with arch and linux-zen are all that keeps me from letting go of manjaro

as seen here pictured below

that problem exists on on the linux-zen kernel and not on mainline or lts and it frustrates me because i prefer to use the kernel most suited for gaming but it often fails to perform that one basic function as illustrated above.

sudo inxi -Fxzmc0    
System:    Kernel: 5.9.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: MATE 1.24.1 
           Distro: EndeavourOS 
Machine:   Type: Desktop System: Gigabyte product: AB350M-DS3H v: N/A serial: N/A 
           Mobo: Gigabyte model: AB350M-DS3H-CF v: x.x serial: N/A UEFI [Legacy]: American Megatrends v: F50d 
           date: 07/02/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech M570 charge: 15% status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360 charge: 100% (should be ignored) 
           status: Discharging 
Memory:    RAM: total: 15.64 GiB used: 1.25 GiB (8.0%) 
           Array-1: capacity: 128 GiB slots: 4 EC: None max module size: 32 GiB note: est. 
           Device-1: DIMM 0 size: No Module Installed 
           Device-2: DIMM 1 size: 8 GiB speed: 3000 MT/s type: DDR4 
           Device-3: DIMM 0 size: No Module Installed 
           Device-4: DIMM 1 size: 8 GiB speed: 3000 MT/s type: DDR4 
CPU:       Info: Quad Core model: AMD Ryzen 5 2400G with Radeon Vega Graphics bits: 64 type: MT MCP arch: Zen 
           rev: 0 L2 cache: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 57518 
           Speed: 2963 MHz min/max: 1600/3600 MHz boost: enabled Core speeds (MHz): 1: 2963 2: 1350 3: 1351 
           4: 1351 5: 2957 6: 1350 7: 1351 8: 1350 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: ASRock driver: amdgpu v: kernel bus ID: 01:00.0 
           Display: server: X.Org 1.20.10 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.39.0 5.9.14-arch1-1 LLVM 11.0.0) 
           v: 4.6 Mesa 20.3.0 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: ASRock 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 0a:00.6 
           Sound Server: ALSA v: k5.9.14-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 
           v: 8.048.03-NAPI port: e000 bus ID: 05:00.0 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus ID: 08:00.0 
           IF: wlan0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.28 TiB used: 615.41 GiB (26.4%) 
           ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket Q size: 931.51 GiB temp: 28.9 C 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
           ID-3: /dev/sdb vendor: SanDisk model: Ultra II 500GB size: 465.76 GiB 
           ID-4: /dev/sdc type: USB vendor: Generic model: Flash Disk size: 1.92 GiB 
Partition: ID-1: / size: 48.97 GiB used: 16.87 GiB (34.4%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: /boot size: 975.9 MiB used: 116.7 MiB (12.0%) fs: ext4 dev: /dev/nvme0n1p8 
           ID-3: /home size: 765.22 GiB used: 306.44 GiB (40.0%) fs: ext4 dev: /dev/nvme0n1p4 
Swap:      ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 46.5 C mobo: N/A gpu: amdgpu temp: 35.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1486 
Info:      Processes: 301 Uptime: N/A Init: systemd Compilers: gcc: 10.2.0 Packages: 1394 Shell: Bash v: 5.1.0 
           inxi: 3.2.00

I’m not quite sure what there is to see in the picture or what the problem is.

3 Likes

Ya, am I missing something? What’s wrong?

1 Like

AH! NO INTERNET CONNECTION HERE!!!

my wired lan connection fails on zen and zen only

Ah. yes, I could see that a clear problem, especially for a gamer. That would without question be an issue.

I’ve had random issues with non lts kernels. And I know it’s infinitely more common if you have “new” hardware, which it looks like your computer is probably as powerful as all 3 of mine.

1 Like

I don’t understand how the zen kernel has anything to do with Manjaro? Does everything work on the linux kernel?

1 Like

I am not a linux networking expert but you may need to install the dkms module for you network card.

Maybe try r8168-dkms

4 Likes

Yeah, that is annoying for sure. It probably due to the wrong interface name being set at default.

For anyone curious as how you normally would be able to solve this:
In a terminal type:

ip a

will give the name needed ( usually after the 2: )

then type:

systemctl enable dhcpcd@(insert name given, normally after the 2: )
ip link set (insert name given, normally after the 2:) up

then a reboot may be required.

2 Likes
DKMS: add completed.
==> The module r8168 conflicts with r8169. You can blacklist it with:
==> echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Install DKMS modules
==> dkms install --no-depmod -m r8168 -v 8.048.03 -k 5.4.83-1-lts
==> dkms install --no-depmod -m r8168 -v 8.048.03 -k 5.9.14-zen1-1-zen
==> dkms install --no-depmod -m r8168 -v 8.048.03 -k 5.9.14-arch1-1

Good news! Module version 8.048.03-NAPI for r8168.ko.xz
exactly matches what is already found in kernel 5.9.14-arch1-1.
DKMS will not replace this module.
You may override by specifying --force.
==> depmod 5.9.14-arch1-1
==> depmod 5.4.83-1-lts
==> depmod 5.9.14-zen1-1-zen
Transaction successfully finished.

lets see how that rolls! and TY! my frustration level often disables my higher thinking processes

the first solution proposed i tried first and it worked.

likely the second one would have worked too but i have no way of testing it now that the first solution proposed did fix the problem

also on the plus side i have remembered to install dmidecode for memory info under inxi (requires sudo inxi) and mesa demos for glx info under the graphics section for inxi. Also i thought to check the bios version of my motherboard which i then upadated to now support 3rd gen amd xt chipsets which means i can now spend 750$ us to buy an AMD Ryzen 9 3900XT 12-core, 24-Threads Unlocked Desktop Processor Without Cooler if i so wish it (yay me). Hard part of updating bios is remembering where gigabit hid svm so i can run a virtual box as well as where they hid the xmmp profile for memory chipset to get it clocked at the right speed.

1 Like

i like this. i should have tried this.

OK so the manjaro team puts into their custom kernel a lot of the features that are found in the zen kernel, its part of what makes manjaro manjaro is their custom kernels and how they manage all that. As i had been using their distro and got used to how my system ran i would not so easily use something else until i found that i could configure that something else to run as well as manjaro does for my use case. This is largely why i had 4 versions of arch installed. I need to see which will do everything manjaro did for me. Endeavour OS does it all now and now that i understand the problem with linux-zen kernel, i now have 2 solutions to get that working. Sadly, the distro i really wanted to use is Artix because it is systemd free. The second i get it configured to do everything i did in manjaro i will move away from systemd based distros in favor of openrc for my daily use. ok ty. have a nice day.