Multiboot artemis neo live iso fails

I’m trying to add endeavouros to a multiboot usb that I’m making, very similar to GLIM, but I can’t get the live iso to work I have this in the grub.cfg

menuentry "EndeavourOS ${variant} ${version}" "${isofile}" "${isoname}" --class endeavouros {
      set isofile=$2
      set isoname=$3
      echo "Using ${isoname}..."
      loopback loop $isofile
      linux (loop)/arch/boot/x86_64/vmlinuz-linux img_dev=$imgdevpath img_loop=$isofile earlymodules=loop
      initrd (loop)/arch/boot/intel-ucode.img (loop)/arch/boot/amd-ucode.img (loop)/arch/boot/x86_64/initramfs-linux.img

Env variables

grub> echo $variant $version $isofile $isoname $imgdevpath
Artemis neo_22_7 /boot/iso/EndeavourOS_Artemis_neo_22_7.iso EndeavourOS_Artemis_neo_22_7.iso /dev/disk/by-uuid/*uuid of the grub and iso partition*

When y run the entry I get

Using EndeavourOS_Artemis_neo_22_7.iso
error: unknown filesystem.
error: you need to load the kernel first.

Press any key to continue...

And pressing any key sends you back to grub
Any help would be appreciated

I’d probably just use Ventoy and be done with it…


(deleted by the author)

AFAIK you cannot use variables like ${variant} right away, you need to define them first. GLIM achieves that by searching for matching patterns and generating a menuentry for each matched pattern.
You can either use GLIM and/or its scripts, hardcode values yourself or use GRUB console for one time manual booting.

GLIM sets $2 and $3 with regexp, see source:

Your script has no idea what $2 and $3 are. First loop mount fails then kernel loading fails because ISO is not mounted.
Or just use Ventoy, really. It works with EndeavourOS. I have gone down the manual ISO booting road, then sticked to Ventoy, until I had no sticks left​:joy:

1 Like

I’m pretty sure $2 $3 are actually defined, they refer to what comes after the menuentry name
menuentry $1 $2 $3

1 Like

What happens when you try to loop mount yourself ie.

loopback loop /boot/iso/EndeavourOS_Artemis_neo_22_7.iso

I think there is no problem when loop mounting or at least it doesn’t give any output, but when I do

linux (loop)/arch/boot/x86_64/vmlinuz-linux

I get

error: unknown filesystem

Also I tried with arch and with arch grub can autocomplete when I do linux (loop)/ but it can’t autocomplete when I loop mount endeavour

That’s correct.
Since it cannot find the kernel (with linux), you should try the same commands in grub command line, to find what’s wrong.

I suppose you know how :wink:
After setting the loop, run the linux, or ls command to autocomplete the file-path.
If you get to boot from there, you’ll see the error.
Post any feedback, if you want. I might help, if I can. :person_shrugging:

1 Like

I tried the following

grub> loopback loop /boot/iso/EndeavourOS_Artemis_neo_22_7.iso
grub> ls (loop)
Device loop: No know filesystem detected - Sector size 512B - Total size 0KiB
grub> linux (loop)/

can’t autocomplete

Have you tried this?

grub> ls (loop)/
1 Like
error: unknown filesystem.

Are you using loop before this menu? loop names should be unique, so we name them in random (loop0, loop1, etc). Can you describe how do you use multibooting, in your custom case?

File system should be recognized, if the appropriate module is loaded (insmod ext2).

I may try booting Artemis tomorrow, if I have some time, just to check…

1 Like

The installer may need the label. Try this var

probe --label --set=cd_label (loop)

and add it in boot-options


Some distros use this. I don’t know how EnOS does it.

Loop name is unique, for now I’m not multibooting just trying to run the live iso from grub because I had the error and decided to test just endeavour, but it is very similar to GLIM, the grub.cfg entry that I’m using is in the original post.
I added the modules for ext2 and ext4 and that solved the unknown filesystem error, tank you a lot I never thought of that.
Now I’m having this error that I remember having a similar error with the arch iso, but I can’t remember how I solved it
Posted in picture because it’s a lot of text to write, also I don’t know if I should open a new thread or keep going on this one

1 Like

AFAIK this does not exist (on grub). ext2 is for all.

Maybe it’s about boot mode. If you boot to UEFI, you might also need tha FAT FS

insmod part_msdos
1 Like

Oh so that’s what grub was trying to tellme at the Welcome to GRUB screen error :sweat_smile:

I think it doesn’t boot into UEFI, but I added part_msdos just in case, but still same error, so I guess it in fact doesn’t boot into UEFI (?

1 Like

So, I’ve been reading and in some posts it is mentioned that maybe there is not enough space, but the usb drive has more than enough, so maybe the loopback is too small (? I don’t know if there is a way to change that, either way I’ll keep searching for solutions

1 Like

Is that a “thing”? :joy:
Maybe there is not enough RAM? But, still, it shouldn’t happen for mounting (I guess…).

Possible error reasons are listed in the message.
Make sure download and copy are good. Sync before quiting copy/transfer to USB.OS does not always report properly an incomplete real transfer (done in memory only). :person_shrugging:
Check sums.