Mullvad VPN - Error Using 'topgrade' Command

Before posting, did a word search for Mullvad. Did not find my error among the topics listed.

I am attempting to run:

to install updates from Mullvad for my system. To my knowledge, it has worked in the past.

I get all the way to confirming the code, but receive this error every time:

==> ERROR: An unknown error has occurred. Exiting... error: failed to build 'mullvad-vpn-2022.5-2': error: packages failed to build: mullvad-vpn-2022.5-2

I asked the TG channel, and got as far as trying:

yay -S mullvad-vpn
but this has not been success for me.

Any help is welcome.

There is a binary from the same maintainer:

You might want to give that a shot.

yay -S mullvad-vpn-bin

Maybe try with ubuntu key server.

# /etc/pacman.d/gnupg/gpg.conf
keyserver hkp://

Even better read this:

      [The default keyserver for dirmngr to use, if none is explicitly given])

the ubuntu keyserver is already the default used since the sks pools are not available anymore:

you suggest the non TLS server… hkps:// (HKP over TLS) respectively. but the server is the same and if blocked in a country you would need to change to a complete other keyserver like one of these:

  • central, verification of email IDs, keys can be deleted.
  • central, verification of email IDs, keys can be deleted, no third-party signatures (i.e. no Web of Trust support).
# /etc/pacman.d/gnupg/gpg.conf
keyserver hkps://

Will change used keyserver for pacman only not if user is using yay … what use users keyring …

you can set default used keyserver systemwide or per user:

per user:


keyserver hkps://

systemwide overriding the hardcoded default from GnuPG package:


keyserver hkps://

I have used this command:

yay -S mullvad-vpn-bin

It looks good, but then I reach this selection:

:: mullvad-vpn-bin and mullvad-vpn are in conflict. Remove mullvad-vpn? [y/N]

Telling terminal to go ahead, I get the error:

error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: mullvad-vpn-bin and mullvad-vpn are in conflict -> exit status 1

User ‘Kresimir’ who has joined the thread is having a different issues with keys. My issue appears to be separate still.

Remove mullvad-vpn first:

sudo pacman -R mullvad-vpn

Then try again:

yay -S mullvad-vpn-bin

That was unbelieably fast and easy. I am now running v22.5 (current).

I marked your answer as solution.

1 Like

Glad you got it resolved!
Have a nice Sunday morning/evening!

:enos_flag: :wave:t5:

Had same issue. This is because of essential port 11371 tcp blocked for out going traffic
@moson suggested alternative way of installing keys.

$sudo curl “” -o some_pub.key

  • % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 10 100 10 0 0 17 0 --:–:-- --:–:-- --:–:-- 17

$ sudo gpg --import some_pub.key

Which results in following error with out key import

gpg: keybox ‘/root/.gnupg/pubring.kbx’ created
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
No luck this time around.Any tweaks please?

Please open a new thread with appropriate title to get the attention of those forum members who are able to help you. This is an already solved thread and its title doesn’t reflect what your issue is about.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.