Muffled Audio

Hello everyone , happy new year

I have 2 problems 1 major and 1 annoying problem that are destroying my entire linux experience

  1. My sound sounds extremely muffled and the sound quality is like im listening from a speaker in the 2000’s unlike in windows which sounds perfectly good

I have a Lenovo Legion 5 gtx 1660ti ryzen 7 4800H KDE X11
here is all my hardware in detail : https://0x0.st/H6q2.txt

here is the output of : pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 1691
Tile Size: 65472
User Name: achno
Host Name: lenovoLegion
Server Name: PulseAudio (on PipeWire 1.0.0)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_06_00.6.analog-stereo.8
Default Source: alsa_output.pci-0000_06_00.6.analog-stereo.8.monitor
Cookie: 6cea:a055

So from what i can see im using pipewire

  • I have searched all over forum posts and the only band-aid solution is using an equalizer like jamesDSP for linux but even though that fixes it a bit , the sound doesnt come close to the windows one.
  1. The second issue is a bump / pop noise everytime a new audio begins playing

From what i gathered its an audio power saving thing and after following the below steps it fixes it sometimes but i still hear those pop sounds a lot but not to the degree i heard them before.

  1. Change the value from 10 → 0
sudo nano /sys/module/snd_hda_intel/parameters/power_save
  1. Change Y → N
sudo nano /sys/module/snd_hda_intel/parameters/power_save_controller
  1. Make these changes persistent on reboot, add options snd-hda-intel power_save=0 power_save_controller=N inside this
sudo nano /etc/modprobe.d/alsa-base.conf

Can anyone help me with these issues? im ready to provide any further info you require, thank you again for reading this