MS SurfacePro7+ || Live USB issues

I have secure boot off
Boot normally in UEFI mode
It boots into DE and runs for a minute or two
It freezes then crash then reboot. There is no log
Tried USB2.0. Same issue
I tried adding modeprobe.blacklist=intel_lpss_pci at grub menu on live USB
Same issue as before
Decided to try different OS
Installed Fedora KDE onto USB. It boots normally. Zero crashes. Fully installed onto my harddrive.

There is something that is triggering the system crash on live USB.

I just purchased a Pro 7 (not plus), I used ventoy for the install, all worked fine.

I think I found the problem. The 2230 M.2 card I bought might be the culprit. It would reboot for no reason. Even in windows. I switched to the OG version 120GB and it works without crashing. So I’m returning it. It’s called, sebrent.

Found it on reddit. It seems to be ongoing issue.

With that being said, I’m getting different brand. I’ll try it again later this week.

Yup 100 percent confirmed. It is the Sebrent ssd failure. I got a different ssd, and it works perfectly well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.