Moving from Nvidia proprietary only to nvidia with prime

Hi, basically the title say it all in short.
I’ve a functional installation with Nvidia proprietary only driver and because I don’t really need the proprietary driver for more than a couple of software I would like to switch to a prime setup, but even searching here or on the archwiki I really struggle to understand properly how all the Nvidia stuff works and every time I try to mess with it I brake my system.
Any good soul which have the time and knowledge to help me so that maybe I can understand it once and for all?

here my system specs
inxi -Fx

Apparently you’re already rendering Xorg on the Intel GPU, but are using the intel driver rather than modesetting. Uninstall xf86-video-intel and things should “just work”.

mm, I’m confused tho, I’ve installed using non-free option and I’ve uninstalled xf86-video-intel now, rebooted and nothing changed. In which I mean that for example if I run Blender “normally” he sees the Nvidia card and let me render with it and if I try to use prime-run to launch something it says “command not found”. Or it is prime-run not viable on gnome wayland? I’m so confused!!!


You’d need nvidia-prime installed for that wrapper to be present.

Your inxi output says you’re running under Xorg. Did that change at some point, and now you’re running under Wayland? If so, what does your inxi report now?

Also keep in mind that GNOME will automatically offload (some?) 3D applications to the dGPU.

I’ve actually tried with both, have both gnome Xorg and gnome Wayland installed, sorry for the confusion. inxi say the same thing under display except for Wayland instead of Xorg.

Ok I’ve missed that sorry

Ok that’s actually incredible!

Also after removing Intel driver I’ve noticed that sometimes gnome have problem resuming after screen timeout on Wayland session. Not yet tested on Xorg for this behavior.

I can’t say for sure that this is going to be the issue for you … but I know my ASUS Zenbook had the problem outlined at the bottom of this page… nVidia Troubleshooting-System does not return from suspend … though if you are only having the screen timeout and no actual suspend, then this is likely not the issue.

I only have the timeout and also I never had this issue before. And I’ve using gnome a lot.
Also now if @jonathon is right it should be using the Intel driver for the DE and so it should not be related ro Nvidia at all