Move BTRFS @home subvolume to new partition

This is related to post Move BTRFS @home subvolume to hdd

I followed the exact steps, but getting “Failed to mount /home partition”

These steps worked fine in manjaro, but would really like to use endeavous os as it is great distro. My laptop has SSD of 24G and HD of 512 G and would like to use the 512G as home instead of 24G

Any help is much appreciated

Can I see the output of:

sudo btrfs subvolume list /
lsblk -o name,type,fstype,mountpoint,uuid
cat /etc/fstab
1 Like

Thanks for reponse… I was able to fix the issue

UUID=5C2B-23BC /boot/efi vfat umask=0077 0 2
UUID=d064ae47-3004-4bed-894f-393c919e1495 / btrfs subvol=/@,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 0
#UUID=d064ae47-3004-4bed-894f-393c919e1495 /home btrfs subvol=/@home,noatime,space_cache,autodefrag,compress=zstd,ssd,noatime,compress=zstd,commit=120,autodefrag,space_cache 0 0
UUID=82764eac-fc97-4b3d-b59d-314837f79b41 /home btrfs subvol=/@home,defaults,noatime,commit=120,compress=zstd 0 0
UUID=d064ae47-3004-4bed-894f-393c919e1495 /var/cache btrfs subvol=/@cache,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 0
UUID=d064ae47-3004-4bed-894f-393c919e1495 /var/log btrfs subvol=/@log,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 0
UUID=d064ae47-3004-4bed-894f-393c919e1495 /var/tmp btrfs subvol=/@tmp,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 0
UUID=d064ae47-3004-4bed-894f-393c919e1495 /opt btrfs subvol=/@opt,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 0
UUID=24eebc6d-aa97-44b9-b68d-e0b2bbaaae60 swap swap defaults,noatime 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0


SSD (Original) #UUID=d064ae47-3004-4bed-894f-393c919e1495 /home btrfs subvol=/@home,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 )0 0
(MDD Updated ) UUID=82764eac-fc97-4b3d-b59d-314837f79b41 /home btrfs subvol=/@home,defaults,noatime,commit=120,compress=zstd 0 0

The reason that MDD was not mounting during booting… was it had “space_cache” as one of the options. AFter i removed it and it started working.

I have edited partition.conf, mount.conf and fstab in calamares to achieve little different subvolume layout.

If anyone interested, i can document the steps if requested.

That is due to a change with kernel 5.15. That option has been removed from the most recent ISO.

Thanks for response

I kept it for SSD and it works…should i remove that option from fstab for SSD?

I would remove it. The new default is space_cache=v2 which is superior.

It isn’t a huge deal either way though.

Thanks…is there step-by-step instructions on how to configure snapper one for root and another for home (both on a separate partition)?

This is my final configuration with / and /home being on different partitions and both having snapper snapshot functionality implemented. I am still trying to see some of the snapper configurations to fine-tune the snapshot process

/ /dev/sdb2[/@] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=256,subvol=/@
├─/.snapshots /dev/sdb2[/@snapshots] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=264,subvol=/@snapshots
├─/opt /dev/sdb2[/@opt] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=261,subvol=/@opt
├─/var/cache /dev/sdb2[/@cache] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=258,subvol=/@cache
├─/var/tmp /dev/sdb2[/@tmp] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=260,subvol=/@tmp
├─/var/log /dev/sdb2[/@log] btrfs rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,commit=120,subvolid=259,subvol=/@log
└─/home /dev/sda[/@home] btrfs rw,noatime,compress=zstd:3,space_cache=v2,commit=120,subvolid=257,subvol=/@home
└─/home/.snapshots /dev/sda[/@snapshots] btrfs rw,noatime,compress=zstd:3,space_cache=v2,commit=120,subvolid=260,subvol=/@snapshots