Mouse not working with Wayland?

I installed the plasma-wayland-session and from my login screen, selected the Wayland Session for KDE. KDE seems to load just fine however my mouse does not work at all. Keyboard words just fine but no mouse. I’ve done a lot of googling and haven’t found anything to point me in the right direction.

Any suggestions?

What sort of mouse is it? USB? Touchpad? PS/2? Bluetooth?
Maybe you can get a clue from looking at the hardware logging in the terminal;

sudo dmesg -T

The -T switch tells you what time the log was made, so if you unplug/re-plug then run the command immediately it should give you a good idea of whether or not the kernel is seeing the mouse now, or if wayland is doing something with it.

Also, have you tried logging into the non-wayland KDE again since?

And what is your login display manager? See here for possible answer: https://bbs.archlinux.org/viewtopic.php?id=253596

I also had it with my touchpad, have you looked in the hardware section menu? When I switched, my settings made on X11 weren’t there, you have to do the settings again.

When you switch back to X11 the settings are still as you left it behind.

A little note, if you use eos-update-notifier, it doesn’t work under Wayland, also if you use Latte dock, it is a bit wonky under Wayland after some hours.

EDIT: I moved the topic to Plasma, since this is a particular Plasma issue. :wink:

1 Like

Thanks for the replies. It is a USB mouse. Mouse works fine at the login screen and it works find under x11 KDE session.

I did just do a test of unplugging and replugging the mouse back in once the Wayland session had loaded and the mouse works fine if I do that. Then I realized my USB keyboard wasn’t working either. I unplugged it and plugged it back in and now it is working fine. So I guess this isn’t a mouse issue but rather a USB issue?

Oddly enough though, prior to unplugging the mouse, keyboard worked fine once Wayland session was loaded as I am able to press ctl+alt+F2 to switch to a terminal and reboot the machine. Once mouse was unplugged and replugged in, keyboard stopped working so I had to unplug it and replug it back in. At that point, both keyboard and mouse worked just fine. Again, this is in a Wayland session only. Both mouse an keyboard work fine under a login screen and under an X11 session.

What kernel are you running?

1 Like

5.11.2 vanilla Arch.
KDE Frameworks 5.79.0
QT Version 5.15.2

I don’t know if the kernel is the issue though, I’ve had this problem for a long time through many different kernel versions. I just switched to using the non Wayland KDE desktop to get around the issue. I would like to play with Wayland again but can’t seem to get past this issue.

My computer is a Ryzen 2700 with an Asus motherboard and a AMD Vega 56 card using the AMDGPU driver.

1 Like

Try the zen kernel. Seems to be better for wayland.

1 Like

The Zen kernel did in fact fix the mouse / usb issue. Kind of surprised that would do it but I won’t complain. On the other hand, it doesn’t look like Wayland likes to recover well from sleep yet which appears to be my next issue to resolve.

Thank you for the suggestion.