Mouse not working when laptop is not plugged in

When I plug it in, it still doesn’t work. my mouse (usb) only works if the laptop was plugged in on startup and stops working if I unplug it.

I’ve tried disabling usb autosuspend, still have the same issue.

Might be worth posting some system information (inxi -Faz), whether it worked in the live installation environment, and any details about what you installed and changed since installation.

System:    Kernel: 5.10.80-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts root=UUID=56173d65-eb9e-4043-be37-0bc45f6b63dd rw quiet
           resume=UUID=3401af0e-c498-4feb-aaf7-6dab52906057 loglevel=3 nowatchdog usbcore.autosuspend=-1 iommu=soft
           Desktop: i3 4.20.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X512DA_F512DA v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: X512DA v: 1.0 serial: <filter> UEFI: American Megatrends v: X512DA.316 date: 02/02/2021
Battery:   ID-1: BAT0 charge: 34.7 Wh (100.0%) condition: 34.7/37.1 Wh (93.4%) volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery
           type: Li-ion serial: N/A status: Not charging cycles: 46
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33535
           Speed: 1229 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1229 2: 1223 3: 1223 4: 1347 5: 1530
           6: 1400 7: 1277 8: 1339
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 03:00.0
           chip-ID: 1002:15d8 class-ID: 0300
           Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-2.2:5 chip-ID: 13d3:56dd
           class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa display-ID: :0
           screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
           bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
           alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.10.80-1-lts running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: rtw_8822be v: N/A
           modules: rtw88_8822be port: f000 bus-ID: 01:00.0 chip-ID: 10ec:b822 class-ID: 0280
           IF: wlan0 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-2.1:4 chip-ID: 13d3:3526
           class-ID: e001 serial: <filter>
           Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled rfk-block: hardware: no software: no
           address: see --recommends
Drives:    Local Storage: total: 491.51 GiB used: 7.76 GiB (1.6%)
           ID-1: /dev/mmcblk0 maj-min: 179:0 type: USB vendor: SanDisk model: SD16G size: 14.57 GiB block-size:
           physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: MBR
           SMART Message: Unknown smartctl error. Unable to generate data.
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFK52.3 temp: 26.9 C
           scheme: GPT
Partition: ID-1: / raw-size: 31.25 GiB size: 30.59 GiB (97.88%) used: 6.88 GiB (22.5%) fs: ext4 dev: /dev/nvme0n1p5
           maj-min: 259:5
           ID-2: /boot/efi raw-size: 32 MiB size: 31.5 MiB (98.41%) used: 283 KiB (0.9%) fs: vfat dev: /dev/nvme0n1p6
           maj-min: 259:6
           ID-3: /home raw-size: 152.31 GiB size: 148.86 GiB (97.73%) used: 897.3 MiB (0.6%) fs: ext4 dev: /dev/nvme0n1p8
           maj-min: 259:8
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 11.72 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:   System Temperatures: cpu: 60.9 C mobo: N/A gpu: amdgpu temp: 60.0 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 214 Uptime: 2m wakeups: 1 Memory: 5.75 GiB used: 1001.8 MiB (17.0%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 Packages: pacman: 815 lib: 204 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.07

It did work in the live environment, I’ve installed tlpui. I haven’t changed much because the mouse wasn’t working after installation.

edit: I’ve added the following to my kernel paramaters:

usbcore.autosuspend=-1 iommu=soft

What’s different between the live environment and your installation? Kernel? TLP?

Immediately after installation, or did you make changes (including a system package update) and then it stopped working?

immediatly after installation

in some cases it can happen that TLP causing devices to power down wrongly… so check if it is the same if TPL is disabled:
sudo systemctl disable tlp
and reboot

It worked somewhat, my mouse workes when the laptop is unplugged. But if I plug it in and then unplug it, my mouse stops working again.

edit: also worth mentioning, when I plug/unplug my laptop, the screen dims a bit.