Mouse lags when CPU loads

I have a problem since my update to Plasma 6, my mouse lags and stutters when the CPU loads, especially just after starting my PC. Where could this come from?
I made a video so you can understand.
Thank you in advance for your answers.

Try x11 ?

I’m already on x11

Try zen kernel ? sudo pacman -S linux-zen linux-zen-headers

1 Like

Sorry to say that but I doubt that changing kernel is the solution to my problem. I would like to keep a simple system and not go for overly complicated solutions.

GPU ? Nvidia or AMD ?

Nvidia GTX 1060 with proprietary driver

Not much to go on from the OP, so I can only guess…

Consider providing some logs:

In the absence of logs, my first guess would be Wayland, but since the OP is running X, that can be ruled out.

My second guess would be baloo being baloo… KDE’s file indexer is notorious for using more CPU than it is reasonable. Consider disabling it:

balooctl suspend
balooctl disable
balooctl purge
1 Like

Hello, I put the commands in, but I’m waiting for the next reboot to see if it works.
From that time, here are the logs:

Hardware info :

Boot log :

If this is a wireless mouse, before going down this rabbit hole of debugging, make sure the USB port you have connected the mouse to is not a USB 3.0 port (the port has a blue inner color), but a 2.0 (the inner color is white or black). If you have no USB 2.0 ports on your machine, make sure to at least not to have anything plugged in into an adjacent USB 3.0 port to the one the mouse is plugged in to. I have bought a cheap USB 2.0 hub just to solve this problem (one can be had for about $3).

You can find here a detailed explanation of the problem.

1 Like

It’s a wired mouse. All the devices I have are wired.
It’s not an hardware problem, I didn’t have the problem on kde 5 or windows 11 (dual boot).

So, after restarting, the problem is still here, eveb with baloo disabled.

Just only the mouse, but a whole Desktop has no problem?
Did you test any game, media player or web browser to play any video without lag except the mouse?

I doubt this problem would be related to your hardware breaking some parts of your system to freeze the entire desktop including mouse movement, because:

kernel: EXT4-fs error (device sda1): ext4_validate_block_bitmap:423: comm ext4lazyinit: bg 10623: bad block bitmap checksum`
kernel: EXT4-fs (sda1): error count since last fsck: 133
kernel: EXT4-fs (sda1): initial error at time 1706567127: ext4_validate_block_bitmap:421
kernel: EXT4-fs (sda1): last error at time 1713208786: ext4_validate_block_bitmap:423
kernel: EXT4-fs error (device sda1): ext4_validate_block_bitmap:423: comm fstrim: bg 10528: bad block bitmap checksum

You probably have a lot of corrupted (system) files on Ext4 that simple ignores some serious problems without your noticing.


There are two newer bios updates for your motherboard which gives some improved compatibility with usb and some other hardware. Latest version is 3.9. I do see the errors on the drive and some drm error for nvidia. Other errors related to cd/dvd drive. The drive errors might cause some issues sooner or later. Not sure if it’s causing the mouse issues but it may be a factor. :man_shrugging:


Well, after several tests I can confirm that it’s not just the mouse that lags but I also had lags on a video opened with MPV. So I guess all the desktop lag.

The EXT4 errors are because of the harddrive ? The system never warned me of a problem regarding this.

Ok, I can do the update, but I didn’t have this problem on Kde 5 or on Windows, despite the fact that I have the old version of the bios.
Yes I might have problems with the disc but I don’t think it has anything to do with this one.

Have you tried another DE or even a WM since you’ve started troubleshooting?

Of course, trying Gnome probably won’t make a difference, so I’d suggest Cinnamon, LxQt, or a WM like Openbox.

The idea is if you still experience lag with something lighter, it’s probably not a KDE problem.

NB: If you decide to try another DE or WM, you can unistall all it’s related packages after by bringing up the same command in your terminal and changing ‘-S’ to ‘-Rs’.


yay -S openbox -> yay -Rs openbox

Another option to try is to create a new user and see if the issue persists.

I don’t have any other DE or WM at the moment so I couldn’t try. I’ll install a new one tomorrow to try and report the results here.

1 Like

I know you have an older board with much older chipset hence why i suggest updating the bios at some point. It looks like you have endeavour installed on the Seagate HD as that is where the file system errors are reported. I suspect there are some problems with or on this drive that may be causing the issue.

My system in installed on sdb so the SanDisk SSD.
The HDD is a secondary hard drive with only games on it.