Mouse cursor stays in resize mode in Dolphin

When I use dolphin, on the left side, there is a bar with shortcuts to my home folder, documents, downloads, music, etc. On the right side of that bar, there is a handle to resize it. If I move my cursor over this resize handle, and then move to the left side onto the bar, the mouse cursor stays in resize mode (cursor looks like this <-|->). This means, that I can’t click anything. After some clicks, the cursor returns to default, and I can click stuff.
If I move the cursor very fast over the handle, this does not happen. Sometimes (I don’t know under what circumstances), this behavior also occurs if I move the mouse to the right side (where the normal file-manager stuff happens).
The same effect happens with the handle for the in Dolphin integrated terminal.
Sorry for my weird formulation. I don’t really know, how to describe this properly.

I have also had this for a few weeks. it occurs whenever I copy a larger file into Dolphin. Seems to last until the background process is finished, only then the cursor goes back to its state.

1 Like

This doesn’t happen for me on KDE. :man_shrugging:

It’s the same with Manjaro KDE, so it must be related.

I’m running the Kde beta 5.21.90

For me it’s definitely not only while copying large files.

Everything is fine in Dolphin for me. Could it be graphics related? I’m using Intel integrated graphics. Perhaps it’s Nvidia related, or something else?

AMD RX 580, amdgpu, nothing special and until recently it worked fine.

It would be helpful if you could post your hardware specs using the log tool from the Welcome screen.

http://ix.io/3nUV

1 Like

Could be this one? Seems to be a problem with Breeze style…

2 Likes

I think this is exactly it and i am running the beta version of Kde. I do see it says double or triple click usually brings it back.

2 Likes

I can confirm that with the double or triple clicks.

1 Like
#################### inxi -Fxxc0z ########################

System:    Kernel: 5.12.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0 
           serial: <filter> BIOS: American Megatrends v: A.40 date: 10/29/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 rev: 0 cache: 
           L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 88803 
           Speed: 4434 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 4434 
           2: 4399 3: 4535 4: 4371 5: 4495 6: 4410 7: 4344 8: 4414 9: 4273 10: 4461 11: 4386 
           12: 4454 
Graphics:  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 2d:00.0 chip-ID: 1002:731f 
           Display: x11 server: X.org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu 
           resolution: <missing: xdpyinfo> 
           OpenGL: 
           renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0 5.12.6-zen1-1-zen LLVM 11.1.0) 
           v: 4.6 Mesa 21.1.1 direct render: Yes 
Audio:     Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus-ID: 2d:00.1 
           chip-ID: 1002:ab38 
           Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487 
           Device-3: Samson Meteor condenser microphone type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.2:5 chip-ID: 17a0:0310 
           Device-4: Sunplus Innovation FHD Camera Microphone type: USB 
           driver: snd-usb-audio,uvcvideo bus-ID: 3-1.3:6 chip-ID: 1bcf:28c4 
           Device-5: Tdlasunnic Sharkoon Gaming DAC Pro S type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:7 chip-ID: be57:020e 
           Sound Server-1: ALSA v: k5.12.6-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
           driver: r8169 v: kernel port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8168 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus-ID: 2a:00.0 chip-ID: 10ec:8125 
           IF: enp42s0 state: down mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-1.1:4 
           chip-ID: 0bda:2550 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 3.31 TiB used: 562.48 GiB (16.6%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> 
           ID-2: /dev/sda vendor: Seagate model: ST2000DX001-1NS164 size: 1.82 TiB speed: 6.0 Gb/s 
           serial: <filter> 
           ID-3: /dev/sdb vendor: Samsung model: SSD 850 EVO 120GB size: 111.79 GiB 
           speed: 6.0 Gb/s serial: <filter> 
           ID-4: /dev/sdc vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
           speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 468.13 GiB used: 329.03 GiB (70.3%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-2: /boot/efi size: 96 MiB used: 25.2 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 53.5 C mobo: N/A gpu: amdgpu temp: 50.0 C mem: 56.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 517 
Info:      Processes: 387 Uptime: 3h 38m Memory: 31.34 GiB used: 10.43 GiB (33.3%) Init: systemd 
           v: 248 Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: 1727 pacman: 1715 flatpak: 12 
           Client: shell wrapper v: 5.1.8-release inxi: 3.3.03 


#################### cat /etc/pacman.conf ########################

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
ILoveCandy
#TotalDownload
# We cannot check disk space from within a chroot environment
#CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

[endeavouros]
SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

I’m using Qogir, not Breeze.

Similar hardware as i have. I have run Qogir also and had no issues. I’ll try it again.

Edit: Is it just Qogir icons or something else?

It’s not always happening.
I have everything Qogir, beside the controls. I just noticed that I actually do have Breeze there. So it might be the Breeze thing.

I’m having issues trying to even install Qogir. I was just getting the spinning wheel. Finally it installed.

Edit: Installed the dark but that’s no good. and it’s not co-operating either.

It is indeed the breeze bug. As proposed in the Bug report, the problem seems to be fixed by switching to Oxygen, as well as by unchecking “Enable extended resize handles” on System Settings->Application Style->Breeze->Configure Style.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.