Mouse cursor size [SOLVED]

Hello friends,
google tells that for increasing XFCE mouse cursor size, there is an option in Settings/mouse and touchpad, but I cannot find anything.

Also, this tutorial:
tells that

xfconf-query --channel xsettings --property /Gtk/CursorThemeSize --set cursor_theme_size

should fix the issue, but I get:

xfconf-query --channel xsettings --property /Gtk/CursorThemeSize --set 25
Property "/Gtk/CursorThemeSize" does not exist on channel "xsettings". If a new property should be created, use the --create option.

Any idea how to fix it?

xsetroot -xcf /usr/share/icons/Adwaita/cursors/left_ptr 48

You can change many things like

  • 48 (=size)
  • Adwaita (icons)
  • etc.

Also, this works here:

xfconf-query -c xsettings --property /Gtk/CursorThemeSize --set 48

Many thanks for your help, This one runs without errors, but the cursor size is still the same

try 32, 24 or 16 for the cursor size.

and check your ~/.Xresources file

Many thanks, but no change

many thanks,
this file does not exist

it can be used to set curor size without using commands… it is a simple format like this:

Xcursor.theme: LyraP-cursors
Xcursor.size: 16
1 Like

You can make that file file yourself.

nano ~/.Xresources

here is mine::

Xft.dpi: 192
Xcursor.theme: capitaine-cursors-light
Xcursor.size: 32
Xft.autohint: 0
Xft.lcdfilter: lcddefault
Xft.hintstyle: hintfull
Xft.hinting: 1
Xft.antialias: 1
Xft.rgba: rgb
1 Like

Did that, then reboot, no change. Tried with size 64, no change. Tried to load resource file with

xrdb ~/.Xresources

no change

If these are not commands, where should I write them? Not in a terminal?

hmm in the file… ~/.Xresources ~ links to your users home…

create the file with your preferred editor or use nano as @anon13373109 suggested already…
and it looks like you do copy pasted the config content … this is not working they are only what others are using you need to set your cursor theme name there …

something very strange happened: using firefox the cursor size is unchanged, but using QPrompt, a teleprompter app, which must be seen from a few meters and required a large cursor, the cursor size is much bigger. So my problem is solved. Just do not know why firefox cursor is small, but for me it does not matter. My problem is solved for now. many thanks to all.

I suppose the addition of that file was the reason why it worked

:melting_face: :dotted_line_face: :sunglasses:

could be the reason :wink:

Moved this topic to kernel and hardware instead of the jobs board.