Mouse cursor keeps jumping to top of screen

I’ve tried different mouse hardware with the same result, and I just did an updated and re-booted, the problem persists.

I’ve got a video of the problem;

I literally can’t use the computer like this. Please help. I really hope the problem is able to be fixed by tomorrow morning, I have to start work from home.

Operating System: EndeavourOS 
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.6.3-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 23.4 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2

This was my own stupid fault!

@Stagger_Lee thanks for your reply in my duplicate thread (which I’ve flagged for deletion).

This was caused by my Wacom tablet pen being nudged when I was rummaging around last night and it was sitting just on the edge of the tablet itself, not enough to cause the behaviour I’d notice when this usually happen - the cursor refuses to move at all. Looks like in this case it was just enough on the edge to cause it to randomly pop up over there.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.