Mouse button 4, 5 and 6 stopped working, worked a week or so ago

Been using button 4 in a game, I’m pretty sure I used it the last two weeks at least. Button 5 and 6 was mapped too, I just didn’t use them a lot. Now button 4, 5 and 6 won’t register in the game.

Tried input-remapper to test the buttons, the normal first 3 buttons work in that program, but the other extra buttons won’t register, just like in the game.

Idk how to troubleshoot the issue further, most stuff I found isn’t about wayland.

Welcome @mihalycsaba

I think there is a lot of information missing here in your post. It would be better if you posted your hardware so it is known what desktop you are using and also what game are you talking about and on what platform?

inxi -Faz | eos-sendlog

Are you able to post a link for your hardware and explain what game and platform you are running? This will be more helpful for those trying to assist you.

Thanks. here’s the log but I don’t see the mouse there, but I checked with hw-probe and input-remapper, they both report this device

The game is shatterline, but I tried mapping the keys in other games too, they don’t work. Had no problem mapping and remapping multiple times. Also tried the buttons in input-remapper, no luck.

Does the mouse not show? Maybe check some logs.


Post the link here:

sudo dmesg | eos-sendlog

I see this is on Steam. Have you checked on the Steam forum for any issues related to this?

I assume the hardware is listed. You just can’t map the buttons? Have you tried others such as wayland-mouse-mapper?

Edit: I’m not really a gamer and i don’t use Gnome and or Wayland much. Have used it on KDE occasionally.

[csaba@csaba-mini ~]$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 258a:1007 SINOWEALTH Game Mouse
Bus 003 Device 004: ID 8087:0aa7 Intel Corp. Wireless-AC 3168 Bluetooth
Bus 003 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 003 Device 002: ID 09da:0260 A4Tech Co., Ltd. KV-300H Isolation Keyboard
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


It doesn’t do anyting with wayland-mouse-mapper.
I have checked the forums, don’t see anything. Also I’m pretty sure I used the buttons in some other game, forgot which, without problems. Tried to map them in Fallout 4 now and didn’t work.

I think it’s not steam related, if I remember correctly they worked in the browser too, as back and forward buttons, just didn’t use them too much. Might be a kernel update or some other update recently, that broke them.

Okay I have downgraded my kernel to 6.0.9, didn’t help. Here’s my /var/cache/pacman/pkg/ could you guys tell me what should I try downgrading out of these?

edit: Here are the files in the cache from the last two weeks

Did you try the lts kernel?

Have you tried remapping using libinput?

Well I might try the lts kernel, but I have already downgraded to 6.0.9, on which I’m sure it worked. I think it’s some other package that changed something, just don’t know which one is related to the mouse.

This supposed to help in remapping on wayland libinput-config, I just didn’t figure it out yet, if it’s even possible to remap mouse with this. input-remapper is supposed to do the same thing, but it only registers the first 3 buttons.

Is there some other way to listen to mouse button events?

Have you tried xev?

It’s a tool provided by the xorg-xev package.

Another way is to use xinput test <device_id>

To figure out the device id, run xinput list

Does that work on wayland?

Oops. didn’t know you are using Wayland. If I remember correctly, there’s a xev equivalent for Wayland in the Aur called wev

Edit: Try libinput test as well. It should work on Wayland, I think?

1 Like

Yeah found wev in yay after you mentioned xev.

[10:    xdg_toplevel] configure: width: 640; height: 480
[09:     xdg_surface] configure: serial: 225
[14:     wl_keyboard] modifiers: serial: 0; group: 16
                      depressed: 00000000
                      latched: 00000000
                      locked: 00000010: Mod2 
[14:     wl_keyboard] enter: serial: 9376; surface: 3
[11:  wl_data_device] data_offer: id: 4278190080
[4278190080:   wl_data_offer] offer: mime_type: text/plain;charset=utf-8
[4278190080:   wl_data_offer] offer: mime_type: text/plain
[4278190080:   wl_data_offer] offer: mime_type: text/html
[4278190080:   wl_data_offer] offer: mime_type: TEXT
[4278190080:   wl_data_offer] offer: mime_type: UTF8_STRING
[4278190080:   wl_data_offer] offer: mime_type: STRING
[4278190080:   wl_data_offer] offer: mime_type: MULTIPLE
[4278190080:   wl_data_offer] offer: mime_type: SAVE_TARGETS
[4278190080:   wl_data_offer] offer: mime_type: TARGETS
[4278190080:   wl_data_offer] offer: mime_type: TIMESTAMP
[11:  wl_data_device] selection: id: 4278190080
[13:      wl_pointer] button: serial: 9377; time: 15041454; button: 272 (left), state: 1 (pressed)
[13:      wl_pointer] frame
[13:      wl_pointer] button: serial: 9378; time: 15041613; button: 272 (left), state: 0 (released)
[13:      wl_pointer] frame
[13:      wl_pointer] button: serial: 9379; time: 15043014; button: 273 (right), state: 1 (pressed)
[13:      wl_pointer] frame
[13:      wl_pointer] button: serial: 9380; time: 15043222; button: 273 (right), state: 0 (released)
[13:      wl_pointer] frame

It sees my first three buttons, left and right click are in the log. But no output for the other 3 buttons. I guess I have to figure out which one of these /var/cache/pacman/pkg/ packages broke the mouse, then I can maybe dowgrade and file a bug report somewhere.

If it only happened after a recent update, checking the pacman logs might help you narrow things down.

You can use a tool called paclog to help you filter the items in the pacman log file. The log file can be found here: /var/log/pacman.log (if you want to view the file directly)

1 Like

Thank you, now this is a nicer log. Filtered for the last month.

Could it be the xkb packages, usbutils, libusb-compat, libxcursor or something else? Do you guys see anything else suspicious that could be related to mouse functionality?

Maybe it’s just the hardware?

Edit: Maybe this will help with setup?

Edit2: You should be able to confirm whether the mouse is busted!


A valid point.

@mihalycsaba Have you tested your mouse on a second computer? Likewise, have you tried to use another mouse on your current machine to see if a second mouse works?

1 Like

Pleased don’t tell us it works on Windows. Does it work on any other linux distro?

1 Like

Have you tried rebooting?

I plugged it in a windows laptop, didn’t work, opened the mouse config app and reseted to default settings… Now it works. Weird thing is, that something disabled the extra buttons, but other setting were unaffected like color, dpi profile…