Mouse accel profile not saving

Hello! My mouse acceleration profile as set in GNOME Tweaks resets anytime I log out or otherwise restart the gnome shell. I set it to Flat but when I open it up again it’ll be like it was by default. In GNOME Tweaks it’ll show it as still being Flat, so I need to change it to another setting and back to Flat to get it back.

How can I get that setting to be permanent?

I’ve actually got the same problem on a fresh install of Fedora, so I don’t think it’s any configs conflicting or anything.

sometimes depend what type of mouse you have.

i got a logitec mx ergo general te scroll spead is bad :slight_smile:

try to open the tweak through your terminal …

try to use dconf-editor mayby it improves https://wiki.archlinux.org/title/Mouse_acceleration

you can set it also there. tell if that changed?

1 Like

if that dont save try to go to .config then and look as example no root owners… thats for later if dconf-editor dont work… ls -la as example should there be a reason it doesnt save

You can try to setup your mouse with piper (if it’s a gaming/branded one)
sudo pacman -S piper

P.S. that software is more for pollingrate/dpi/buttons/leds

Anyway you can just make the config file read only, the one that is being written by gnome tweaks

It applies successfully and if I do it through dconf, it’ll still show as “flat” even when it’s reset to “default” and the accel is back on. That’s the whole thing: the dconf user file stays flat as I want it to, but the actual behavior does not. So that’s a bust, same behavior as tweaks where it says flat but reverts to accel. Where should I look for the config tweaks / dconf are editing? Running chown recursively on my config folder didn’t change anything. Note that other settings in tweaks will stay permanently, it’s just this that resets.

Also, unfortunately piper does not support my mouse, a Logitech M570 trackball. I would just put it on the mouse like ringo suggested, but I’m able to get it perfect with the flat profile…it just never stays that way.

Try this with libinput https://wiki.archlinux.org/title/Mouse_acceleration#Disabling_mouse_acceleration

Otherwise try to look here ~/.config/dconf/user for mouse acceleration stuff

dconf watch / in terminal should show you which files are being altered

NVM I didn’t read. Another solution might be a script to set the acceleration off at the start of the session

Yeah, I retried the libinput solution and it didn’t change anything.

I guess a startup script to turn accel on and then off might have to be the workaround I use.

A script has me covered on login, but is there a way to set it to run when the shell restarts as well? If I restart the gnome shell while logged in the script won’t run again, leaving me with an accelerated mouse. I assume that means if it crashes and restarts in place, my accel will be reset.

Fwiw, here’s the script for anyone who stumbles upon this in the future:

#!/bin/bash
gsettings set org.gnome.desktop.peripherals.mouse accel-profile 'default'
gsettings set org.gnome.desktop.peripherals.mouse accel-profile 'flat'

X-GNOME-Autostart-enabled=true might do the trick?

That’s already in the .desktop file I made to run the script, and it doesn’t run on shell restart while still logged in.

I’m not an expert in bash scripts but in theory you can run a script that does nothing while the shell is active and when it restarts you run a second script that changes the acceleration of the mouse and runs the first script (which detects the stuff) again, something like this

while ps -p $PID; do sleep 1; done ; script2

Disclamer : I can be totally wrong on this one xd

I also got m570 only is broken mx ergo does les feel less plastic…my only personal issie with both is scroll speed sometimes with imwheel script but it has some bugs