Mount.cifs fails since update to Endeavouros with 5.18.9-arch1-1

mount.cifs fails since the last update.
Output of uname -a is: 5.18.9-arch1-1 #1 SMP PREEMPT_DYNAMIC Sat, 02 Jul 2022 21:03:06 +0000 x86_64 GNU/Linux
Error is: mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg). dmesg does not give additional hints.
The entry in /etc/fstab is:
//NAS.fritz.box/sync /home/wolfgang/nas/sync cifs cred=/home/wolfgang/.config/nascred,uid=1000,gid=1000,nobrl
One user reported, that adding vers=2.0 solved the problem. This did not work for me.
Since this failure of mount.cifs appeared after the last update while 5.18.8-arch1-1 worked flawlessly, I am looking for changes of arguments of mount.cifs. I do not find any.
Any Ideas?
Thank you!

If it worked in 5.18.8 then it’s likely a regression; if so it should be fixed in 5.18.10.

You could also try some other kernels, just in case.

My cifs works fine with latest kernel. Here is my fstab syntax:

/192.XXX.X.XXX/Public  /mnt/purkki  cifs  uid=bitterhalt,credentials=/home/bitterhalt/.smbcredentials,iocharset=utf8,uid=1000,gid=1000,noperm,rw,vers=3.0,noauto,x-systemd.automount,x-systemd.after=network-online.target 0 0

Mine is also working; this is the command I use to mount my host (EOS) system from my VM (Arch w/5.18.9 kernel):

mount -t cifs -o user=ajgringo619,uid=1000,gid=1000 //dss-endeavouros/shared-files /mnt

CIFS version is reported as 3.1.1.

I am seeing this, mounting via fstab not working, mounting manually does:

sudo mount -t cifs -o rw,guest,vers=3.0 //192.168.0.2/Steve /media/mycloud

Interesting :thinking:

I woke us this morning and my cifs did not mount after sleep. In log there errors caught my attention:

This is first time when this happen so definitely some kind of kernel issue.
For me this seems to be random and does not happen everytime.

There is this:

2 Likes