Most Steam games not launching

Most of my installed Steam games won’t launch. The only one’s that do work are the following:

Left 4 Dead 2
Dragon’s Dogma: Dark Arisen

Every other game does not launch at all. I have Steam Play enabled and have tried to start Deep Rock Galactic through Proton 4.11, Proton 5.13, Proton 6.3, Proton Experimental and GE-Proton7-55. None of them work. All I see is Steam telling me :"Launching"and then quickly goes back to “Play”. No black screen, no error message or anything else.
This log appears for the game:“Deep Rock Galactic”

Proton: 1680202810 experimental-7.0-20230330
SteamGameId: 548430
Command: ['/run/media/alec/Local Disk/SteamLibrary/steamapps/common/Deep Rock Galactic/FSD.exe', '-nohmd']
Options: {'enablenvapi', 'forcelgadd'}
depot: 0.20230314.45274
pressure-vessel: 0.20230314.0 scout
scripts: 0.20230314.0
soldier: 0.20230314.45274 soldier 0.20230314.45274
Kernel: Linux 6.2.11-arch1-1 #1 SMP PREEMPT_DYNAMIC Thu, 13 Apr 2023 16:59:24 +0000 x86_64
Language: LC_ALL None, LC_MESSAGES None, LC_CTYPE None

Here is my inxi -Faz

type or paste code hereSystem:
  Kernel: 6.2.11-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: initrd=\5fd10adba9f54b5499e740c55afad7be\6.2.11-arch1-1\initrd
    nvme_load=YES nowatchdog rw
    root=UUID=22e39a45-ca08-4779-bdf2-10d5dd70fa41 nvidia-drm.modeset=1
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF B450-PLUS GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2008
    date: 12/06/2019
  Device-1: ps-controller-battery-84:30:95:7f:34:07 model: N/A serial: N/A
    charge: N/A status: full
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2458 high: 3600 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2803 2: 2068
    3: 3599 4: 2196 5: 2200 6: 2196 7: 2056 8: 2200 9: 3600 10: 2196 11: 2196
    12: 2196 bogomips: 86268
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: none off: DP-1,DP-2
    empty: DP-3,HDMI-A-1,HDMI-A-2 bus-ID: 08:00.0 chip-ID: 10de:2504
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 101 s-size: 966x272mm (38.03x10.71")
    s-diag: 1004mm (39.51")
  Monitor-1: DP-1 note: disabled pos: primary,right model: Samsung S22C300
    serial: <filter> built: 2013 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  Monitor-2: DP-2 note: disabled pos: left model: Samsung S22F350
    serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    3060/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 1-2:3 v: kernel chip-ID: 046d:0825 pcie:
    gen: 3 class-ID: 0102 serial: <filter> speed: 8 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 08:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: Sony DualShock 4 [CUH-ZCT2x] type: USB
    driver: playstation,snd-usb-audio,usbhid bus-ID: 1-4:5 chip-ID: 054c:09cc
    class-ID: 0300
  API: ALSA v: k6.2.11-arch1-1 status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-9:7 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 4.09 TiB used: 536.63 GiB (12.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD40EFAX-68JH4N0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A82 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS500G2B0B-00YS70 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: GPT
  ID-1: / raw-size: 464.78 GiB size: 456.41 GiB (98.20%)
    used: 52.14 GiB (11.4%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  Alert: No swap data was found.
  System Temperatures: cpu: 48.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 310 Uptime: 23m wakeups: 1 Memory: 15.55 GiB
  used: 4.46 GiB (28.7%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1369
  pm: pacman pkgs: 1362 libs: 462 tools: yay pm: flatpak pkgs: 7 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.26

As you can see I do have an Nvidia GPU. I do have both nvidia-utils and lib32-nvidia-utils installed.
Running: pacman -Qsq | grep -iE “vulkan|nvidia”

type lib32-nvidia-utils

And running: pacman -Qs | grep -iE “amd”

local/amd-ucode 20230210.bf4115c-1
    Microcode update image for AMD CPUs

So I should have all the requirements installed. I genuinely have no idea how to fix this and have looked around here on the forum for similar issues but nothing seemed to help. Let me know if I should provide any more information.

-can you update your UEFI motherboard ?

  • add this option on kernel boot

  • have you try with linux-zen ?

1 Like

Thanks, I will update my motherboard when I’m home. What is linux-zen?

you can read this

1 Like

Fwiw,I always use steam flatpak so I know everything together is meant to be together. While not all games work, almost all do with the help of protondb.

1 Like

this is not good

I fixed it! After some further testing and googling I figured out that the only games that did not start were non-native linux games installed on my secondary hard drive. That is the reason why Left 4 Dead 2 (native linux support) and Dragons Dogma (accidentally installed SSD which is my primary disk) worked.

So what I did is after backing my data up I formatted my hard drive to ext4 format and mounted my disk in /home//LocalDisk1/ in fstab. After rebooting my computer Steam was able to detect the new drive and I finally managed to start a game that used proton on my 4TB hard drive.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.