Monitors not working via Dock and HDMI port

Hi all,

i am having troubles with my machine and external monitors. I have a lenovo thunderbolt 3 workstation Dock and a lenovo p1 gen4 (dedicated graphics). The dock connects through usb c and a slimtip connector for charging. My monitors are two lenovo 4k monitors, connected to the dock via Displayport (Monitors are set to DP 1.2; highest diplayport protocoll to chose on this side). The LAN connection and other peripherals connected to the dock are recognized and working. Both monitors are not recognized and are not showing up in system settings.
External monitors are also not working when connected via hdmi directly (and using optimus manager to switch to nvdia graphics).
I have already fiddled arround with optimus while connected to the dock, as i already had those issues with integrated vs. dedicated graphics in a prior install of EOS and Manjaro. I had it working with EOS in the past, though I had to change the refresh rate to 30Hz for both external displays in order to have both working ( with 60Hz only one was working). With this, both showed up in system settings - now none show up.
I also installed Bolt and have the thunderbolt settings avaliable in sys.settings. The dokc is recognized and is trusted (but soetimes it shows as offline wihle connected)

I have checked it with the windows partition on my system and its working flawlessly, BIOS on my laptop and the firmware on the dock are up to date, have checked that yesterday before pulling the plugs for about 10 minutes.

Have you guys any suggestions, or can i provide you with logs which can help in this matter? I have checked the X11 log, there are four dp connections which are saying “disconnected”… I am out of help now, this issue has plaing me for long now…

Allright, i maybee solved this or got my sollution - i have reinstalled the nvidia drivers with nvidia-inst -p (actually nvidia-inst -pf) and set optimus startup default to hybrid. This is the only setup i get it to work with. whe i switch modes and log in again, it still not recognizes my monitors and i have to restart my system ( simply switching back to hybrid doeasnt do it)
I guess i have my workaround! :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.