Monitor's native resolution disappeared after update

I was gone for the past few weeks, and I just arrived back home and updated my computer. After updating, my main monitor (2560x1440) seems to have lost the ability to run at its native resolution. According to KDE’s settings app it now maxes out at 2048x1152, which is bizzare and not a resolution I’ve ever seen before.

I tried kscreen-doctor output.DP-1.mode.2560x1440@60, but it failed, complaining about not being able to find the output mode. I’m not sure what’s going on or how to even begin to attempt fixing this.

Welcome back @hazelnot :wave: :sunglasses: :enos_flag:

Are you able to confirm it’s doing this in both X11 and Wayland?

Hi, I haven’t tried X11, but also I managed to fix it since I 5 minutes ago when I posted this

I just reinstalled mesa and amd-ucode and now everything’s back to normal. Not sure which of the two fixed it, but one of them did lol

1 Like

Glad it’s sorted, and thanks for sharing the solution :+1: One to keep in mind.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.