Monitor won't stay asleep on XFCE or KDE

Thanks for checking this out. It’s a minor problem, but I appreciate any help I can get.

I have a two computers sharing one monitor. A Windows machine via Display Port. Endeavour on HDMI.

In XFCE the monitor would wake up seconds after it loses video signal from going to sleep. Once awake it does not go sleep again. It would also revert the refresh rate from 144 to 60 MHz.

In KDE, I’m not losing the refresh rate, but the monitor still wakes up a few seconds after going to sleep. The monitors UI displays a message saying “No signal” which is normal, then it wakes up, and won’t go back to sleep.

I’ve tried every combination of power settings that I can think of and turned all the screen locking options off to just test the monitor sleep, same problem.

So what’s common denominator that would be involved with display power management across different display servers?

The same hardware configuration functions as expected with Windows and Ubuntu, so I know it’s not a hardware specific.

Thanks again for any assistance.

I know wireless (maybe wired too) mice can keep a device from going into standby, or knocking them out of standby.

1 Like

Thanks for the reply!

I made sure it wasn’t the mouse input by turning the sensitivity way down, so that it barely moved.

Also, it doesn’t wake up when using Ubuntu on the same machine.

The fact that it loses refresh rate settings in XFCE tells me there’s more going on as well. It’s like it’s detecting a new monitor or something and gives it default values.

Taking shots in the dark… Could it be related to the fact that the card is using its second output (HDMI)? I don’t have two Display Ports on the monitor, or I would just go with that. Is there a way of telling the OS that the cards second output is default? Would that have any impact? I just don’t know anything about the Linux video stack, so I have very little frame of reference.

It may be that the monitor when put to sleep starts polling inputs and cycles through each when it no longer detects a signal? When the monitor enters dpms, it starts polling inputs so it can light up whatever input gets connected without the user having to manually select the input. This can cause havoc with drivers sometimes. This is just a guess?

1 Like

The monitor definitely cycles through inputs when one goes to sleep. It goes into a standby state if all the inputs are off.

I reverted to Ubuntu to double check, installing the latest LTS, and it also has the same problem now.

So then I started digging into kernal bugs, and low and behold, there are all sorts of bug reports on power state issues with Baffin core cards (AMD RX560’s). ¯_(ツ)_/¯

I’m guessing my last version of Ubuntu was using a different kernel than the newer LTS, and it just picked up the bug from upstream.

Compiling custom kernels to weed out bugs is a bit beyond my experience, though I understand it conceptually.

Do your monitors have DDC/CI in the settings for the monitors?

On EOS you can check your monitor settings with.

xset q

You can also set DPMS in X

As far as Windows goes. Check all your power management settings for the monitor. Then you can also check the advanced power management settings.