Monitor stuck on 30hz

Hello everyone,

I’ve got my computer connected to my tv (LG 65SM8200PLA) for multimedia purposes. Mainly watching movies, series and browsing the web.

My setup:

                     ./o.                  mainstream@oxytocine-pc 
                   ./sssso-                ----------------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: HP ProDesk 600 G4 DM 
             `-/ossssssssssssso/.          Kernel: 5.17.2-arch3-1 
           `-/+sssssssssssssssso+:`        Uptime: 20 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 881 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 4096x2160 
    .:///ossssssssssssssssssssssssso++:    DE: Budgie 10.6.1 
  `:////ssssssssssssssssssssssssssso+++.   WM: Mutter(Budgie) 
`-////+ssssssssssssssssssssssssssso++++-   Theme: Orchis-dark [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: Tela-circle-dark [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: gnome-terminal 
  `:::::::::::::::::::::::::------``       CPU: Intel i5-8600T (6) @ 3.700GHz 
                                           GPU: Intel CoffeeLake-S GT2 [UHD Graphics 630] 
                                           Memory: 3335MiB / 7726MiB 

I came from elementary os and manjaro and playback wasn’t a big issue there. Now it’s all choppy and lagging. I’ve already tried different hdmi cables but no luck. At the moment i purchased a displayport to hdmi cable (60hz) to try, but still my monitor is stuck at 30 hz in budgie

Have you tried changing the refresh rate in the display settings in Budgie?

I tried changing the refresh rate in the system settings but it’s limited to 30hz in budgie…

I just checked a lower spec system with elementary os, that it 60hz is available. When running xrandr it outputs 60 hz + for 4k.