Monitor Numbering Wrong

I fix almost all issues myself. But this one eludes me!

The Viewsonic should been number 1 and the graphics tablet number 2.
Shouldn’t matter I guess but it’s driving me crazy! :crazy_face:
Some apps open in tablet even tho Viewsonic set to primary.

Thanks :purple_heart:

Try setting the primary display with xrand.
Something like this:
xrandr --output DP-4 --primary

DP-4 is my monitor. You just need to know whic monitor your’s is

Tried that earlier… Viewsonic still 2 though it’s set as primary. Some apps still open in graphics tablet.
Is there a .conf file that need to be edited?

The ? mark on the screenshot means what exactly.?