Monitor freezes and only updates after moving the mouse

This issue started after an update almost a month ago. Everything is working fine on the main monitor, but on the secondary one the screen doesn’t update until I move the mouse. For example, if I open a terminal on the second monitor, it doesn’t show the terminal until I move the mouse on that monitor.

Please give use more information.
What is the GPU you are using? How good is the cable that connects the other monitor?
Have your tried different refresh rates? different resolutions?
does this happen in a live environment?

Hello, I have same issue after i update my system. I tried more than 5 monitors same issue is all of them with my device.
Below you can find the information of my system.
System:
Kernel: 6.3.1-arch1-1 arch: x86_64 bits: 64 Desktop: bspwm v: 0.9.10
Distro: EndeavourOS
Machine:
Type: Laptop System: Dell product: G3 3579 v: N/A
serial:
Mobo: Dell model: 03TF0Y v: A00 serial: UEFI: Dell
v: 1.19.0 date: 12/06/2021
Battery:
ID-1: BAT0 charge: 14.7 Wh (69.3%) condition: 21.2/56.0 Wh (37.9%)
volts: 15.3 min: 15.2
CPU:
Info: 6-core model: Intel Core i7-8750H bits: 64 type: MT MCP cache:
L2: 1.5 MiB
Speed (MHz): avg: 1616 min/max: 800/4100 cores: 1: 800 2: 800 3: 800
4: 2200 5: 2200 6: 800 7: 2200 8: 2200 9: 2200 10: 800 11: 2200 12: 2200
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia
v: 530.41.03
Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
loaded: intel,nvidia unloaded: modesetting dri: i965
gpu: i915,nvidia,nvidia-nvswitch resolution: 1: 1920x1080~60Hz
2: 1920x1080~60Hz
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2)
Audio:
Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
API: ALSA v: k6.3.1-arch1-1 status: kernel-api
Server-1: PipeWire v: 0.3.70 status: active
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
IF: wlan0 state: up mac: 7c:2a:31:38:89:a7
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp2s0 state: down mac: 54:bf:64:2e:5a:b3
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: see --recommends
Drives:
Local Storage: total: 1.14 TiB used: 143.91 GiB (12.3%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
ID-2: /dev/sdb vendor: SK Hynix model: SC311 SATA 256GB size: 238.47 GiB
Partition:
ID-1: / size: 233.38 GiB used: 143.91 GiB (61.7%) fs: ext4 dev: /dev/sdb2
ID-2: /boot/efi size: 299.4 MiB used: 328 KiB (0.1%) fs: vfat
dev: /dev/sdb1
Swap:
ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
System Temperatures: cpu: 42.0 C pch: 50.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 341 Uptime: 18m Memory: 15.48 GiB used: 2.75 GiB (17.8%)
Shell: Bash inxi: 3.3.26

Hello there,

My problem got fixed after I uninstalled xf86-video-intel package.

Command:
sudo pacman -Rsc xf86-video-intel

I thank you for your time :smiley: .
Regards,
Rukesh Shrestha