Module WL was not found

I know I’m in the minority, but my PC came with a Broadcom WiFi adapter, so as any sane person would do, I wanted to get my PC connected to WiFi, so I followed a handy tutorial on how to install Broadcom drivers.

However when I had to run sudo modprobe wl it just responded with: FATAL: Module wl not found in directory /lib/modules/5.13.12-arch1-1; I was wondering if there was any way I could fix it, thanks in advance!

Which tutorial?

This one! I hope it helps!

Which specific broadcom wifi hardware do you have and what does pacman -Q | grep broadcom return?

broadcom-wl-dkms 6.30.223.271-28.

Can we also see:

uname -a
pacman -Q | grep "^linux"\

uname -a:
Linux EndeavourOS 5.13.12-arch1-1 #1 SMP PREEMPT Wed, 18 Aug 2021 20:49:03 +0000 x86_64 GNU/Linux

pacman -Q | grep "^linux"\:
linux 5.13.12.arch1-1
linux-api-headers 5.12.3-1
linux-atm 2.5.2-7
linux-firmware 20210818.c46b8c3-1
linux-headers 5.13.12.arch1-1

Please tell me if I’ve misspelled anything!

What happens if you run

sudo dkms autoinstall

It does… nothing?

vr-39

Are you able to show

inxi -Na

Alright here it is!
Please don’t judge me, I’m installing this on my Mac Mini.

Is it just the WiFi that doesn’t work? Ethernet works?

I still haven’t tried it with Ethernet, my router is on the other side of my house, but USB-Tethering works!

You may have to blacklist some modules. See if this does anything.

sudo rmmod b43
sudo modprobe wl

Edit: If that doesn’t do anything you may need the b43-firmware from the AUR and reboot.

yay -S b43-firmware

This is all that happens when I run them, I tried going to the address it linked to, but all that appeared was a 404 screen.

Should be as it works for me.

yay -S b43-firmware

Edit: It starts the package build … no issue.

[ricklinux@eos-kde ~]$ yay -S b43-firmware
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  b43-firmware-6.30.163.46-1

  1 b43-firmware                     (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

Wifi isn’t working and you are trying to fix it using yay which is trying to retrieve b43-firmware over the network.
So you will need to connect using an ethernet cable.
God help us all when they start making boxes without RJ-45 connectors.

1 Like

Broadcom BCM4331 Wireless Chipset.

There are two major options to get this chipset working in Arch Linux:

The b43-firmwareAUR package contains the open-source, reverse-engineered firmware for the chipset.

The broadcom-wl and broadcom-wl-dkms packages ship with the propriety, restricted-license drivers for the chipset.

See Broadcom wireless for more information.

archwiki say :wink:

So yes the firmware is needed for the device.
dmesg | grep bcrm would show that the load of the firmware failed.