Module for rtl8188eus wifi adapter not working properly

After 3 modules for the wifi adapter rtl8192eu failed one after another in the course of 1 year, and they just won’t even get installed on my system anymore, I found another wifi adapter with different chip rtl8188eus. Installed the corresponding module listed as number three on this page
using the following commands:

* git clone
* cd 8188eu-dkms
* makepkg -si
* echo -e “8188eu\n\nloop” | sudo tee /etc/modules
* sudo grub-mkconfig -o /boot/grub/grub.cfg
* sudo mkinitcpio -p linux

It is kind of working, max internet speed is 2 Mbit/s out of possible 8 Mbit/s. Sometimes it is working, but then speed drops to almost zero.

I don’t know what I did wrong? Maybe there is something else needs to be done? maybe blacklist some module?

Please post some systeminfo.

At the least: inxi -aN

Hopefully this will give forum members some ideas.

Also, out of curiosity, what is your intention with the following line?

$ inxi -aN
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 08:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter
    driver: rtl8188eu type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 3-1:2 chip-ID: 0bda:8179 class-ID: 0000 serial: 7898E81E7BCD

I don’t know. When I installed first driver for another wifi adapter there was this code that I found on some internet forum. there one person used it to install the same module for the same wifi adapter. I thought it was necessary. I did not question the wisdom of this person, because his code worked at that time.

1 Like

Have you tried just installing a package from the AUR using yay?
This is the standalone driver for that chip.

yay -S 8188eu-dkms-git


$ dkms status
8188eu/, 6.3.2-arch1-1, x86_64: installed

Rebooted the PC.
Speedtest proudly shows 0.89 Mbps.
I don’t think the problem is solved.
Are all wifi adapters with realtek chips this bad?

I would try to boot with the lts kernel. For kernel 6.3, rtl8188eu chips are supported by the rtl8xxxu driver.

I bought an Atheros AR9172 wifi adapter. It works with the default driver. No need to install anything.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.