Modprobe: module not found but in modules.order

Hello there,

I was checking my journalctl -b output and noticed a error caused by a module named ‘igen6_edac’.
However I wanted to see information but modinfo igen6_edac, output: module not found.
I tried:

modprobe --resolve-alias igen6_edac
modprobe: FATAL: Module igen6_edac not found in directory /lib/modules/6.7.5-arch1-1
modprobe --resolve-alias igen6_edac
modprobe: FATAL: Module igen6_edac not found in directory /lib/modules/6.7.5-arch1-1
grep -r igen6_edac /lib/modules/6.7.6-arch1-1/
grep: /lib/modules/6.7.6-arch1-1/modules.alias.bin: binary file matches
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004641sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004621sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004602sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004601sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00009A14sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d0000458Dsv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004589sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004585sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004581sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004536sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004534sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d0000451Asv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004518sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004532sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d0000452Esv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d0000452Csv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004516sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d0000452Asv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004528sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.alias:alias pci:v00008086d00004514sv*sd*bc*sc*i* igen6_edac
/lib/modules/6.7.6-arch1-1/modules.order:kernel/drivers/edac/igen6_edac.ko
grep: /lib/modules/6.7.6-arch1-1/modules.dep.bin: binary file matches
/lib/modules/6.7.6-arch1-1/modules.dep:kernel/drivers/edac/igen6_edac.ko.zst:

Does someone know what is it caused by?

Thanks in advance.

It looks like you’re running kernel 6.7.6 and it’s looking for the module in the directory for kernel 6.7.5.

I’m guessing you updated your system, the update included a kernel update, and you did not reboot.

A reboot will likely solve this.

1 Like

Oh boy, I really forgot to reboot after the update. Sorry.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.