Mkfs.ext4 stuck on creating journal

I am trying to format an external drive which was ntfs. But when I try to do it, it gets stuck on Creating journal (262144 blocks):
I can’t even ctrl+c it. ctrl+z worked then i did sudo pkill mkfs.ext4 as it was stopped (ctrl+z).
Any help would be greatly appreciated.
Thank you!

Maybe you should start with writing a new MBR, then create a partition, both can be done with
and then finally use mkfs.ext4 to format it.
First unmount the partition or fdisk can’t work.

Edit: In case there is an I/O error fdisk will show

I have had this happen a few times for some reason in gparted.

I formatted it to fat 32 first and then was able to go to ext4. I have absolutely no idea why it worked, but it did.

If you are wanting to end up with ext4, I would use either Gparted or KDE Partition Manager to install a new gpt partition table, then format that partition with ext4, assuming you want the entire drive to be a single partition.


1 Like

If you remember the HDD issue which I gone through, the recommended solution was to format all the NTFS partitions to ext4.

So, I think your methodology should be helpful in this case.

1 Like