Missing titlebars in XFCE 4.14

I am not sure if an update did it, I do not recall playing with the window manager, but I notice that there are no titlebars and no min/max buttons.

I killed xfwm4 but it instantly restarts back with the same parameters.

I searched for solutions on the net. Someone said I should delete .cache/sessions/xfce*. But I do not have any such files in that dir. I had xfwm4* files and I deleted them. No effect.

Another solution suggests linking /usr/lib/libxfconf-0.so.3 to libxfconf-0.so.2.0.0 instead of the current libxfconf-0.so.3.0.0. Before I try all this, I thought I will post the question in this forum.

Anyone has any idea what is going on?

My EOS is fully updated to the current versions of everything.

I’m running XFCE as well - and having no such difficulties (on multiple Arch-based machines - an Arco, 2 Arch, 2 EndeavourOS - and on others as well. I’ve not heard of this!

I would start out by trying some re-theming - as titlebars and window buttons are handled separately from the ‘main’ theme. I don’t know how familiar you are with XFCE, but the themes to check out are chosen from the Window Manager in settings, rather than in Appearance. Perhaps you could let us know what you have chosen for that, and we could check if if it has problems for us too…

I figure always to start with the simplest stuff first - it so often ends up being less work!

@sanjaychak01 It was me proposing that as a solution, but that was a temporary fix until xfce released a fix for that bug. but that was 1 year ago. I’ve deleted that symlink not long after creating it, as it was not needed anymore because the official fixes worked.

try launching a program (that exhibits the problems you have mentioned) through terminal and check out the output. You can start searching a fix based on that output.

@freebird54, the theme selected is Arc-Darker. This is quite a common theme I have used earlier. Could it be the source of this issue?

@nate, I ran mousepad from the terminal. It came up without title bars. But no messages in the console indicating anything amiss.

Well - it might be corrupted, or something else might have happened to it - so I would start out by trying out some alternatives to see if your missing parts come back. Removing and reinstalling some packages might be in order once we have more of a handle on it…

@freebird54, selected Coldsteel theme, logged out and in. Still the same.

what about qt apps do they also lack decorations? virtualbox, clementine are two popular qt5 apps.

@nate, yes virtualbox comes up without titlebars

I’m running xfwm4 4.14.2-1 at the moment - do you know your version?

Chromium shows the min/max buttons. But does not respond to double clicking. I guess there is no title bar of the application, but just the tabs bar, where the buttons are.

@freebird54, how do I find the exact version? pacman -Q gives the following

libxfce4ui 4.14.1-3
libxfce4util 4.14.0-2
xfce4-appfinder 4.14.0-2
xfce4-battery-plugin 1.1.3-2
xfce4-datetime-plugin 0.8.0-2
xfce4-mount-plugin 1.1.3-2
xfce4-netload-plugin 1.3.2-2
xfce4-notifyd 0.6.1-1
xfce4-panel 4.14.4-1

There’s a few ways - but I used:

pacman -Q | grep xfwm4

@freebird54, Is it that I am running 4.14.1 and you are running 4.14.2 ? I did pacman -Syu. No updates for me.

@freebird54, ok that command says “xfwm4 4.14.2-1”

Yeah - this particular build is pretty new (I put it together about1.5 weeks ago I think) so it’ll be up-to-date for 2 reasons :grin:

You could try uninstalling and re-installing it, to see if it makes a difference - it might write over any misconfigured .conf files that way…

@freebird54, so I uninstall just xfwm package and reinstall again?

That’s what I’d try next:

# pacman -R xfwm4
then
# pacman -S xfwm4

(the # means in root mode or use sudo to activate)

@freebird54, thanks. Let me try that. I guess, I will have to do from a console.

The second part - probably!